СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д17 C1 № 59

В электронную таблицу занесли данные о тестировании учеников. Ниже приведены первые пять строк таблицы:

 

ABCD
1округфамилияпредметбалл
2CУченик 1обществознание246
3ВУченик 2немецкий язык530
4ЮУченик 3русский язык576
5СВУченик 4обществознание304

 

В столбце А записан округ, в котором учится ученик; в столбце В — фамилия; в столбце С — любимый предмет; в столбце D — тестовый балл. Всего в электронную таблицу были занесены данные по 1000 ученикам.

 

Выполните задание.

Откройте файл с данной электронной таблицей (расположение файла Вам сообщат организаторы экзамена). На основании данных, содержащихся в этой таблице, ответьте на два вопроса.

1. Сколько учеников в Северо-Западном округе (СЗ) выбрали в качестве любимого предмета русский язык? Ответ на этот вопрос запишите в ячейку Н2 таблицы.

2. Каков средний тестовый балл у учеников Западного округа (3)? Ответ на этот вопрос запишите в ячейку Н3 таблицы с точностью не менее двух знаков после запятой.

 

 

task19.xls

Решение.

task19.xls

 

1. Запишем в ячейку H2 следующую формулу =ЕСЛИ(A2="СЗ";C2;0) и скопируем ее в диапазон H3:H1001. В таком случае, в ячейку столбца Н будет записываться название предмета, если ученик из Северо-Западного округа (СЗ) и «0», если это не так. Применив операцию =ЕСЛИ(H2="русский язык";1;0), получим столбец(J) с единицами и нулями. Далее, используем операцию =СУММ(J2:J1001). Получим количество учеников, которые считают своим любимым предметом русский язык. Таких 11 человек.

2. Для ответа на второй вопрос используем операцию «ЕСЛИ». Запишем в ячейку E2 следующее выражение: =ЕСЛИ(A2="З";D2;0), в результате применения данной операции к диапазону ячеек Е2:Е1001, получим столбец, в котором записаны баллы только учеников Западного округа. Просуммировав значения в ячейках, получим сумму баллов учеников: 57 807. Далее посчитаем количество учеников Западного округа с помощью команды =СЧЁТЕСЛИ(A2:A1001;"З"), получим: 108. Разделив сумму баллов на количество учеников, получим: 535,25 — искомый средний балл.

 

Ответ: 1) 11; 2) 535,25.

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1303.