СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д17 C1 № 580

Среди учеников 5−11 классов проводили социологический опрос. Результаты занесли в электронную таблицу. Ниже приведены первые пять строк таблицы:

 

ABCDE
1ФамилияИмяКлассЛюбимый предметОценка за любимый предмет
2АлександровАртемий5информатика4
3АлександроваАлександра6алгебра4
4АнайАнгыр10геометрия4
5АнанкинаПолина8русский язык4
6АндреевЯрослав7информатика5

 

Каждая строка таблицы содержит запись об одном ученике. В столбце А записана фамилия, в столбце В - имя, в столбце С — класс, в столбце D — любимый предмет, в столбце Е — оценка за любимый предмет.

 

Выполните задание.

Откройте файл с данной электронной таблицей (расположение файла Вам сообщат организаторы экзамена). На основании данных, содержащихся в этой таблице, ответьте на два вопроса.

1. Сколько учеников любят алгебру? Ответ на этот вопрос запишите в ячейку H2 таблицы.

2. Какой процент учеников 7 класса имеют оценку 3 за любимый предмет? Ответ на этот вопрос с точностью не менее 2 знаков после запятой запишите в ячейку H3 таблицы.

 

 

task19.xls

Решение.

task19.xls

 

1. В ячейку Н2 запишем формулу, которая определяет, сколько всего учеников любят алгебру: =СЧЁТЕСЛИ(D2:D219; "алгебра").

2. Для ответа на второй вопрос в столбце G для каждого учащегося запишем его оценку за любимый предмет, если он учится в 7 классе, и 0 в обратном случае. В ячейку G2 запишем формулу =ЕСЛИ(C2=7;Е2;0). Скопируем формулу во все ячейки диапазона G2:G219. Далее, чтобы определить количество учащихся, у которых оценка за любимый предмет 3, запишем в ячейку I1 формулу =СЧЁТЕСЛИ(G2:G219;"3"). Сосчитаем количество учеников 7 класса. В ячейку I2 запишем формулу =СЧЁТЕСЛИ(С2:С219;7). Выразим полученное значение в процентах от общего числа учеников. Результат запишем в ячейку НЗ: =I1*100/I2 Возможны и другие варианты решения, например с использованием сортировок, фильтров и т. д.

 

Ответ: 1) 25; 2) 35,14.