информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 550

Запишите зна­че­ние переменной y, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM y, i AS INTEGER

y = 0

FOR i = 1 TO 3

    y = y + 4 * i

NEXT i

PRINT y

y = 0

for i in range(1,4):

    y = y + 4 * i

print (y)

ПаскальАлгоритмический язык

var y, i: integer;

begin

    y := 0;

    for i := 1 to 3 do

        y := y + 4 * i;

    writeln(y);

end.

алг

нач

   цел y, i

   y := 0

   нц для i от 1 до 3

      y := y + 4 * i

   кц

   вывод y

кон

С++

#include <iostream>

using namespace std;

int main() {

     int y = 0;

     for (int i = 1; i <= 3; i++)

          y = y + 4 * i;

     cout << y;

     return 0;

}

 

Пояснение.

Цикл «for i := 1 to 3 do» вы­пол­ня­ет­ся три раза. Каж­дый раз пе­ре­мен­ная y уве­ли­чи­ва­ет­ся на 4*i. По­сколь­ку изначально y = 0, после вы­пол­не­ния программы по­лу­чим: y = 4 + 8 + 12 = 24.