информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 490

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 2

FOR k = 1 TO 5

    s = s * 2

NEXT k

PRINT s

s = 2

for k in range(1, 6):

    s = s * 2

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 2;

    for k := 1 to 5 do

        s := s * 2;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 2

   нц для k от 1 до 5

      s := s * 2

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 2;

     for (int k = 1; k <= 5; k++)

          s = s * 2;

     cout << s;

     return 0;

}

 

Пояснение.

Цикл «for k := 1 to 5 do» вы­пол­ня­ет­ся пять раз. Каж­дый раз пе­ре­мен­ная s умно­жа­ет­ся на 2. По­сколь­ку из­на­чаль­но s = 2, после вы­пол­не­ния про­грам­мы по­лу­чим: s = 2 · 2 · 2 · 2 · 2 · 2 = 64.