информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 470

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 1

FOR k = 3 TO 0

STEP −1

    s = s * 3

NEXT k

PRINT s

s = 1

for k in range(4, 0, −1):

    s = s * 3

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 1;

    for k := 3 downto 0 do

        s := s * 3;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 1

   нц для k от 3 до 0

   шаг −1

      s := s * 3

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 1;

     for (int k = 3; k >= 0; k−−)

          s = s * 3;

     cout << s;

     return 0;

}

 

Пояснение.

Цикл «for k := 3 downto 0 do» вы­пол­ня­ет­ся четыре раза. Каж­дый раз пе­ре­мен­ная s умно­жа­ет­ся на 3. По­сколь­ку изначально s = 1, после вы­пол­не­ния программы по­лу­чим: s = 1 · 3 · 3 · 3 · 3 = 81.