информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 430

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 1

FOR k = 0 TO 9

    s = s + 5

NEXT k

PRINT s

s = 1

for k in range(10):

    s = s + 5

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 1;

    for k := 0 to 9 do

        s := s + 5;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 1

   нц для k от 0 до 9

      s := s + 5

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 1;

     for (int k = 0; k <= 9; k++)

          s += 5;

     cout << s;

     return 0;

}

 

Пояснение.

Цикл «for k := 0 to 9 do» вы­пол­ня­ет­ся десять раз. Каж­дый раз пе­ре­мен­ная s уве­ли­чи­ва­ет­ся на 5. По­сколь­ку изначально s = 1, после вы­пол­не­ния программы по­лу­чим: s = 1 + 10 · 5 = 51.