СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 15 № 421

Выберите ОДНО из предложенных ниже заданий: 15.1 или 15.2.

 

Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. У Робота есть девять команд. Четыре команды — это команды-приказы:

 

вверх вниз влево вправо

 

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑ вниз ↓, влево ← , вправо →. Если Робот получит команду передвижения сквозь стену, то он разрушится. Также у Робота есть команда закрасить, при которой закрашивается клетка, в которой Робот находится в настоящий момент.

Ещё четыре команды — это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений:

 

сверху свободно  снизу свободно  слева свободно  справа свободно

 

Эти команды можно использовать вместе с условием «если», имеющим следующий вид:

если условие то

последовательность команд

все

 

Здесь условие — одна из команд проверки условия. Последовательность команд — это одна или несколько любых команд-приказов. Например, для передвижения на одну клетку вправо, если справа нет стенки, и закрашивания клетки можно использовать такой алгоритм:

если справа свободно то

вправо

закрасить

все

 

В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:

если (справа свободно) и (не снизу свободно) то

вправо

все

 

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

нц пока условие

последовательность команд

кц

 

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно

вправо

кц

 

 

Выполните задание.

На бесконечном поле имеется вертикальная стена. Длина стены неизвестна. От нижнего конца стены вправо отходит горизонтальная стена также неизвестной длины. Робот находится в клетке, расположенной слева от вертикальной стены и выше горизонтальной стены. На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные ниже горизонтальной стены и примыкающие к ней. Требуется закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).

Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для произвольного размера поля и любого допустимого расположения стен внутри прямоугольного поля. При исполнении алгоритма Робот не должен разрушиться, выполнение алгоритма должно завершиться. Алгоритм может быть выполнен в среде формального исполнителя или записан в текстовом редакторе. Сохраните алгоритм в текстовом файле.

 

 

15.2 Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. Необходимо определить среднюю зарегистрированную скорость всех автомобилей. Если не менее двух автомобилей двигались со скоростью не больше 40 км/ч, выведите «YES», иначе выведите «NO».

Программа получает на вход число проехавших автомобилей N (1 ≤ N ≤ 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300.Программа должна сначала вывести среднюю скорость, с точностью до одного знака после запятой, затем «YES» или «NO».

 

Пример работы программы:

 

Входные данныеВыходные данные
4
74
69
63
96
75.5
NO

Решение.

15.1 Следующий алгоритм выполнит требуемую задачу.

 

нц

пока справа свободно

вправо

кц

 

нц

пока не справа свободно

вниз

кц

 

вправо

 

нц пока не сверху свободно

закрасить

вправо

кц

 

15.2 Решение

 

var N, a, i, num: integer; s, ave: real;

begin

s := 0.0; num := 0;

readln(N);

for i := 1 to N do

begin

readln(a); s := s+a;

if a <= 40 then num := num + 1;

end;

ave := s/N;

writeln(ave:6:1);

if num >= 2 then writeln('YES')

else writeln('NO')

end.

 

Для проверки правильности работы программы необходимо использовать следующие тесты:

 

Входные данныеВыходные данные
1

3

50

81

65

65,3

NO

2

1

35

35

NO

3

2

40

40

40

YES

4

3

15

25

140

60

YES

Спрятать решение · ·
Julia Samarina 04.09.2016 18:57

В задание 20.1 ошибка

Если горизонтальная стена будет доходить до конца поля, то при данном алгоритме робот разрушится, что противоречит условию задачи.

Если последнее действие :

нц пока не свер­ху сво­бод­но

за­кра­сить

впра­во

кц

 

заменить на :

нц пока не сверху свободно

закрасить

если справа свободно то вправо всё

кц

 

Робот не разрушится.

Сергей Никифоров

В таких заданиях обычно подразумевается, что поле бесконечное, то есть описанная вами ситуация невозможна.

Дмитрий Султанов 12.02.2017 20:22

В задании 20.2, в 12 строке лишний знак Л "if num >= 2 then writeln(ЛYES')".

Александр Великий 08.05.2017 18:49

20.2 - В условии ошибка

Выходные данные

Должно быть:

75.5

NO