СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 410

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 3

FOR k = 0 TO 9

    s = s + 3

NEXT k

PRINT s

s = 3

for k in range(10):

    s = s + 3

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 3;

    for k := 0 to 9 do

        s := s + 3 ;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 3

   нц для k от 0 до 9

      s := s + 3

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 3;

     for (int k = 0; k <= 9; k++)

          s += 3;

     cout << s;

     return 0;

}

 

Пояснение.

Цикл «for k := 0 to 9 do» вы­пол­ня­ет­ся десять раз. Каж­дый раз пе­ре­мен­ная s уве­ли­чи­ва­ет­ся на 3. По­сколь­ку изначально s = 3, после вы­пол­не­ния программы по­лу­чим: s = 3 + 10 · 3 = 33.