СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 39

В элек­трон­ную таб­ли­цу за­нес­ли дан­ные о те­сти­ро­ва­нии учеников. Ниже при­ве­де­ны пер­вые пять строк таблицы:

 

ABCD
1округфамилияпредметбалл
2CУченик 1обществознание246
3ВУченик 2немецкий язык530
4ЮУченик 3русский язык576
5СВУченик 4обществознание304

 

В столб­це А за­пи­сан округ, в ко­то­ром учит­ся ученик; в столб­це В — фамилия; в столб­це С — любимый предмет; в столб­це D — тестовый балл. Всего в элек­трон­ную таб­ли­цу были за­не­се­ны дан­ные по 1000 ученикам.

 

Выполните задание.

Откройте файл с дан­ной элек­трон­ной таб­ли­цей (расположение файла Вам со­об­щат ор­га­ни­за­то­ры экзамена). На ос­но­ва­нии данных, со­дер­жа­щих­ся в этой таблице, от­веть­те на два вопроса.

1. Сколько уче­ни­ков в Северо-Восточном окру­ге (СВ) вы­бра­ли в ка­че­стве лю­би­мо­го пред­ме­та математику? Ответ на этот во­прос за­пи­ши­те в ячей­ку Н2 таблицы.

2. Каков сред­ний те­сто­вый балл у уче­ни­ков Юж­но­го окру­га (Ю)? Ответ на этот во­прос за­пи­ши­те в ячей­ку Н3 таб­ли­цы с точ­но­стью не менее двух зна­ков после запятой.

 

 

task19.xls

Пояснение.

task19.xls

 

1. За­пи­шем в ячей­ку H2 сле­ду­ю­щую фор­му­лу =ЕСЛИ(A2="СВ";C2;0) и ско­пи­ру­ем ее в диа­па­зон H3:H1001. В таком случае, в ячей­ку столб­ца Н будет за­пи­сы­вать­ся на­зва­ние предмета, если уче­ник из Северо-Восточного окру­га и «0», если это не так. При­ме­нив опе­ра­цию =ЕСЛИ(H2="математика";1;0), по­лу­чим столбец(J) с еди­ни­ца­ми и нулями. Далее, ис­поль­зу­ем опе­ра­цию =СУММ(J2:J1001). По­лу­чим ко­ли­че­ство учеников, ко­то­рые счи­та­ют своим лю­би­мым пред­ме­том математику. Таких уче­ни­ков 17.

2. Для от­ве­та на вто­рой во­прос ис­поль­зу­ем опе­ра­цию «ЕСЛИ». За­пи­шем в ячей­ку E2 сле­ду­ю­щее выражение: =ЕСЛИ(A2="Ю";D2;0), в ре­зуль­та­те при­ме­не­ния дан­ной опе­ра­ции к диа­па­зо­ну ячеек Е2:Е1001, по­лу­чим столбец, в ко­то­ром за­пи­са­ны баллы толь­ко уче­ни­ков Юж­но­го округа. Про­сум­ми­ро­вав зна­че­ния в ячейках, по­лу­чим сумму бал­лов учеников: 66 238. Далее по­счи­та­ем ко­ли­че­ство уче­ни­ков Юж­но­го окру­га с по­мо­щью ко­ман­ды =СЧЁТЕСЛИ(A2:A1001;"Ю"), получим: 126. Раз­де­лив сумму бал­лов на ко­ли­че­ство учеников, получим: 525,69 — искомый сред­ний балл.

 

Ответ: 1) 17; 2) 525,70.

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1302.