СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д9 № 370

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей про­грам­мы. Текст про­грам­мы при­ведён на пяти язы­ках про­грам­ми­ро­ва­ния.

 

Бей­сикPython

DIM k, s AS INTEGER

s = 50

FOR k = 1 TO 9

    s = s − 3

NEXT k

PRINT s

s = 50

for k in range(1,10):

    s = s − 3

print (s)

Пас­кальАл­го­рит­ми­че­ский язык

var s,k: integer;

begin

    s := 50;

    for k := 1 to 9 do

        s := s − 3;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 50

   нц для k от 1 до 9

      s := s − 3

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 50;

     for (int k = 1; k <= 9; k++)

          s −= 3;

     cout << s;

     return 0;

}

 

Ре­ше­ние.

Цикл «for k := 1 to 9 do» вы­пол­ня­ет­ся де­вять раз. Каж­дый раз пе­ре­мен­ная s умень­ша­ет­ся на 3. По­сколь­ку из­на­чаль­но s = 50, после вы­пол­не­ния про­грам­мы по­лу­чим: s = 50 − 9 · 3 = 23.