СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д8 № 370

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на пяти языках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 50

FOR k = 1 TO 9

    s = s − 3

NEXT k

PRINT s

s = 50

for k in range(1,10):

    s = s − 3

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 50;

    for k := 1 to 9 do

        s := s − 3;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 50

   нц для k от 1 до 9

      s := s − 3

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 50;

     for (int k = 1; k <= 9; k++)

          s −= 3;

     cout << s;

     return 0;

}

 

Решение.

Цикл «for k := 1 to 9 do» выполняется девять раз. Каждый раз переменная s уменьшается на 3. Поскольку изначально s = 50, после выполнения программы получим: s = 50 − 9 · 3 = 23.