информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 350

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 50

FOR k = 0 TO 8

    s = s − 4

NEXT k

PRINT s

s = 50

for k in range(9):

    s = s − 4

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 50;

    for k := 0 to 8 do

        s := s − 4;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 50

   нц для k от 0 до 8

      s := s − 4

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 50;

     for (int k = 0; k <= 8; k++)

          s −= 4;

     cout << s;

     return 0;

}

 

Пояснение.

Цикл «for k := 0 to 8 do» вы­пол­ня­ет­ся де­вять раз. Каж­дый раз пе­ре­мен­ная s умень­ша­ет­ся на 4. По­сколь­ку из­на­чаль­но s = 50, после вы­пол­не­ния про­грам­мы по­лу­чим: s = 50 − 9 · 4 = 14.