Задания
Версия для печати и копирования в MS Word
Тип 15 № 341

Выберите ОДНО из предложенных ниже заданий: 15.1 или 15.2.

 

15.1

Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. У Робота есть девять команд. Четыре команды — это команды-приказы:

вверх вниз влево вправо

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑ вниз ↓, влево ← , вправо →. Если Робот получит команду передвижения сквозь стену, то он разрушится. Также у Робота есть команда закрасить, при которой закрашивается клетка, в которой Робот находится в настоящий момент.

Ещё четыре команды — это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений:

сверху свободно  снизу свободно  слева свободно  справа свободно

Эти команды можно использовать вместе с условием «если», имеющим следующий вид:

если условие то

последовательность команд

все

 

Здесь условие — одна из команд проверки условия. Последовательность команд — это одна или несколько любых команд-приказов. Например, для передвижения на одну клетку вправо, если справа нет стенки, и закрашивания клетки можно использовать такой алгоритм:

если справа свободно то

вправо

закрасить

все

 

В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:

если (справа свободно) и (не снизу свободно) то

вправо

все

 

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

нц пока условие

последовательность команд

кц

 

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно

вправо

кц

 

На бесконечном поле имеется вертикальная стена. Длина стены неизвестна. От верхнего конца стены вправо отходит горизонтальная стена также неизвестной длины. Робот находится в клетке, расположенной слева от нижнего края вертикальной стены.

На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные левее вертикальной стены и выше горизонтальной стены и прилегающие к ним. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рис.).

Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для произвольного размера поля и любого допустимого расположения стен внутри прямоугольного поля. При исполнении алгоритма Робот не должен разрушиться. Алгоритм напишите в текстовом редакторе и сохраните в текстовом файле. Название файла и каталог для сохранения Вам сообщат организаторы экзамена.

 

15.2 Напишите программу, которая в последовательности целых чисел определяет сумму двух наибольших и сумму двух наименьших. Программа должна вывести две этих суммы в указанном порядке. Программа получает на вход целые числа, количество введённых чисел не известно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000.

В последовательности не менее двух чисел.

Спрятать решение

Решение.

15.1 Команды исполнителя будем записывать жирным шрифтом, а комментарии, поясняющие алгоритм и не являющиеся его частью, — курсивом. Начало комментария будем обозначать символом «|».

 

| Двигаемся вверх, пока не дойдём до конца вертикальной стены, закрашивая все клетки на пути

нц пока не справа свободно

закрасить

вверх

кц

 

| Закрасим угловую клетку и переместимся в начало горизонтальной стены

закрасить

вправо

 

| Двигаемся вправо до конца горизонтальной стены, закрашивая все клетки на пути

нц пока не снизу свободно

закрасить

вправо

кц

 

Возможны и другие варианты решения.

 

15.2 Вариант решения на языке Паскаль.

 

var a, max, max2, min, min2: integer; 

begin

min:= 30001;

min2:= 30001;

max:= -30001;

max2:= -30001;

readln(a);

if (a = 0) then begin

min := 0;

min2 := 0;

max := 0;

max2 := 0;

end;

while true do

begin

if (a = 0) then break;

if (a <= min) and (a<>0) then

begin

min2 := min;

min := a;

end

else if (a <= min2) then

min2:=a;

if a >= max then

begin

max2:=max;

max:=a;

end

else if (a >= max2) then

max2:=a;

readln(a);

if a = 0 then break;

end;

writeln(max+max2); writeln(min+min2);

end.

Спрятать критерии
Критерии проверки:

Критерии оценивания выполнения задания 15.1Баллы
Алгоритм правильно работает при всех допустимых исходных данных2
При всех допустимых исходных данных верно следующее:

1) выполнение алгоритма завершается, и при этом Робот не разбивается;

2) закрашено не более 10 лишних клеток;

3) остались незакрашенными не более 10 клеток из числа тех, которые должны были быть закрашены

1
Задание выполнено неверно, т. е. не выполнены условия, позволяющие поставить 1 или 2 балла0
Максимальный балл2

 

Критерии оценивания выполнения задания 15.2Баллы
Предложено верное решение. Программа правильно работает на всех приведённых выше тестах. Программа может быть записана на любом языке программирования2
Программа выдаёт неверный ответ на одном из тестов, приведённых выше1
Программа выдаёт на тестах неверные ответы, отличные от описанных в критерии на 1 балл0
Максимальный балл2