СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 329

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 8

FOR k = 3 TO 8

    s = s + 8

NEXT k

PRINT s

s = 8

for k in range(3,9):

    s = s + 8

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 8;

    for k := 3 to 8 do

        s := s + 8;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 8

   нц для k от 3 до 8

      s := s + 8

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 8;

     for (int k = 3; k <= 8; k++)

          s += 8;

     cout << s;

     return 0;

}

 

Пояснение.

Цикл «for k := 3 to 8 do» вы­пол­ня­ет­ся шесть раз. Каж­дый раз пе­ре­мен­ная s уве­ли­чи­ва­ет­ся на 8. По­сколь­ку изначально s = 8, после вы­пол­не­ния программы по­лу­чим: s = 8 + 6 · 8 = 56.

Источник: Демонстрационная вер­сия ГИА—2013 по информатике.