СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 259

В электронную таблицу занесли данные о калорийности продуктов. Ниже приведены первые пять строк таблицы:

 

ABCDE
1ПродуктЖиры, гБелки, гУглеводы, гКалорийность, Ккал
2Арахис45,226,39,9552
3Арахис жареный522613,4626
4Горох отварной0,810,520,4130
5Горошек зелёный0,258,355

 

В столбце А записан продукт; в столбце В — содержание в нём жиров; в столбце С — содержание белков; в столбце D — содержание углеводов и в столбце Е — калорийность этого продукта.

 

Выполните задание.

Откройте файл с данной электронной таблицей (расположение файла Вам сообщат организаторы экзамена). На основании данных, содержащихся в этой таблице, ответьте на два вопроса.

1. Сколько продуктов в таблице содержат меньше 25 г жиров и меньше 25 г белков? Запишите число этих продуктов в ячейку H2 таблицы.

2. Какова средняя калорийность продуктов с содержанием углеводов более 50 г? Ответ на этот вопрос запишите в ячейку HЗ таблицы с точностью не менее двух знаков после запятой.

 

 

task19.xls

Пояснение.

task19.xls

 

1. Запишем в ячейку G2 следующую формулу =ЕСЛИ(И(B2<25;С2<25);1;0) и скопируем ее в диапазон G3:G1001. В таком случае, в ячейку столбца G будет записываться единица, если продукт содержит меньше 25 г жиров и меньше 25 г белков. Применив операцию =СУММ(G2:G1001), получим ответ: 823.

2. Запишем в ячейку J2 следующее выражение: =СУММЕСЛИ(D2:D1001;">50";E2:E1001), в результате получим сумму калорий продуктов с содержанием углеводов более 50 г: 46 601. Применив операцию =СЧЁТЕСЛИ(D2:D1001;">50"), получим количество продуктов с содержанием углеводов более 50 г: 133. Разделив, получим среднее значение калорийности продуктов с содержанием углеводов более 50 г: 350,38.

 

Ответ: 1) 823; 2) 350,38.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1313.