СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 239

В элек­трон­ную таб­ли­цу за­нес­ли дан­ные о ка­ло­рий­но­сти продуктов. Ниже при­ве­де­ны пер­вые пять строк таблицы:

 

ABCDE
1ПродуктЖиры, гБелки, гУглеводы, гКалорийность, Ккал
2Арахис45,226,39,9552
3Арахис жареный522613,4626
4Горох отварной0,810,520,4130
5Горошек зелёный0,258,355

 

В столб­це А за­пи­сан продукт; в столб­це В — содержание в нём жиров; в столб­це С — содержание белков; в столб­це D — содержание уг­ле­во­дов и в столб­це Е — калорийность этого продукта.

 

Выполните задание.

Откройте файл с дан­ной элек­трон­ной таб­ли­цей (расположение файла Вам со­об­щат ор­га­ни­за­то­ры экзамена). На ос­но­ва­нии данных, со­дер­жа­щих­ся в этой таблице, от­веть­те на два вопроса.

1. Сколь­ко про­дук­тов в таб­ли­це со­дер­жат мень­ше 25 г жиров и мень­ше 25 г углеводов? За­пи­ши­те число этих про­дук­тов в ячей­ку H2 таблицы.

2. Ка­ко­ва сред­няя ка­ло­рий­ность про­дук­тов с со­дер­жа­ни­ем бел­ков боль­ше 20 г? Ответ на этот во­прос за­пи­ши­те в ячей­ку H3 таб­ли­цы с точ­но­стью не менее двух зна­ков после запятой.

 

 

task19.xls

Пояснение.

task19.xls

 

1. За­пи­шем в ячей­ку G2 сле­ду­ю­щую фор­му­лу =ЕСЛИ(И(B2<25;D2<25);1;0) и ско­пи­ру­ем ее в диа­па­зон G3:G1001. В таком случае, в ячей­ку столб­ца G будет за­пи­сы­вать­ся единица, если про­дукт со­дер­жит мень­ше 25 г жиров и мень­ше 25 г углеводов. При­ме­нив опе­ра­цию =СУММ(G2:G1001), по­лу­чим ответ: 696.

2. За­пи­шем в ячей­ку J2 сле­ду­ю­щее выражение: =СУММЕСЛИ(C2:C1001;">20";E2:E1001), в ре­зуль­та­те по­лу­чим сумму ка­ло­рий про­дук­тов с со­дер­жа­ни­ем бел­ков более 20 г: 37 786. При­ме­нив сле­ду­ю­щую опе­ра­цию =СЧЁТЕСЛИ(C2:C1001;">20"), по­лу­чим ко­ли­че­ство про­дук­тов с со­дер­жа­ни­ем бел­ков более 20 г: 129. Разделив, по­лу­чим сред­нее зна­че­ние про­дук­тов с с со­дер­жа­ни­ем бел­ков более 20 г: 292,91.

 

Ответ: 1) 696; 2) 292,91.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1312.