СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д17 C1 № 199

В электронную таблицу занесли данные о калорийности продуктов. Ниже приведены первые пять строк таблицы:

 

ABCDE
1ПродуктЖиры, гБелки, гУглеводы, гКалорийность, Ккал
2Арахис45,226,39,9552
3Арахис жареный522613,4626
4Горох отварной0,810,520,4130
5Горошек зелёный0,258,355

 

В столбце А записан продукт; в столбце В — содержание в нём жиров; в столбце С — содержание белков; в столбце D — содержание углеводов и в столбце Е — калорийность этого продукта.

 

Выполните задание.

Откройте файл с данной электронной таблицей (расположение файла Вам сообщат организаторы экзамена). На основании данных, содержащихся в этой таблице, ответьте на два вопроса.

1. Сколько продуктов в таблице содержат меньше 20 г углеводов и больше 20 г белков? Запишите число этих продуктов в ячейку Н2 таблицы.

2. Какова средняя калорийность продуктов с содержанием углеводов 0 г? Ответ на этот вопрос запишите в ячейку НЗ таблицы с точностью не менее двух знаков после запятой.

 

 

task19.xls

Решение.

task19.xls

 

1. Запишем в ячейку G2 следующую формулу =ЕСЛИ(И(D2<20;C2>20);1;0) и скопируем ее в диапазон G3:G1001. В таком случае, в ячейку столбца G будет записываться единица, если продукт содержит меньше 20 г углеводов и больше 20 г белков. Применив операцию =СУММ(G2:G1001), получим ответ: 118.

2. Запишем в ячейку J2 следующее выражение: =СУММЕСЛИ(D2:D1001;0;E2:E1001), в результате получим сумму калорий с нулевым содержанием углеводов: 36 536. Применив операцию =СЧЁТЕСЛИ(D2:D1001;0), получим количество продуктов с нулевым содержанием углеводов: 152. Разделив, получим среднее значение продуктов с содержанием углеводов 0 г: 240,37.

 

Ответ: 1) 118; 2) 240,37.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1310.