информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 199

В элек­трон­ную таб­ли­цу за­нес­ли дан­ные о ка­ло­рий­но­сти продуктов. Ниже при­ве­де­ны пер­вые пять строк таблицы:

 

ABCDE
1ПродуктЖиры, гБелки, гУглеводы, гКалорийность, Ккал
2Арахис45,226,39,9552
3Арахис жареный522613,4626
4Горох отварной0,810,520,4130
5Горошек зелёный0,258,355

 

В столб­це А за­пи­сан продукт; в столб­це В — содержание в нём жиров; в столб­це С — содержание белков; в столб­це D — содержание уг­ле­во­дов и в столб­це Е — калорийность этого продукта.

 

Выполните задание.

Откройте файл с дан­ной элек­трон­ной таб­ли­цей (расположение файла Вам со­об­щат ор­га­ни­за­то­ры экзамена). На ос­но­ва­нии данных, со­дер­жа­щих­ся в этой таблице, от­веть­те на два вопроса.

1. Сколько про­дук­тов в таб­ли­це со­дер­жат мень­ше 20 г уг­ле­во­дов и боль­ше 20 г белков? За­пи­ши­те число этих про­дук­тов в ячей­ку Н2 таблицы.

2. Какова сред­няя ка­ло­рий­ность про­дук­тов с со­дер­жа­ни­ем уг­ле­во­дов 0 г? Ответ на этот во­прос за­пи­ши­те в ячей­ку НЗ таб­ли­цы с точ­но­стью не менее двух зна­ков после запятой.

 

 

task19.xls

Пояснение.

task19.xls

 

1. За­пи­шем в ячей­ку G2 сле­ду­ю­щую фор­му­лу =ЕСЛИ(И(D2<20;C2>20);1;0) и ско­пи­ру­ем ее в диа­па­зон G3:G1001. В таком случае, в ячей­ку столб­ца G будет за­пи­сы­вать­ся единица, если про­дукт со­дер­жит мень­ше 20 г уг­ле­во­дов и боль­ше 20 г белков. При­ме­нив опе­ра­цию =СУММ(G2:G1001), по­лу­чим ответ: 118.

2. За­пи­шем в ячей­ку J2 сле­ду­ю­щее выражение: =СУММЕСЛИ(D2:D1001;0;E2:E1001), в ре­зуль­та­те по­лу­чим сумму ка­ло­рий с ну­ле­вым со­дер­жа­ни­ем углеводов: 36 536. При­ме­нив опе­ра­цию =СЧЁТЕСЛИ(D2:D1001;0), по­лу­чим ко­ли­че­ство про­дук­тов с ну­ле­вым со­дер­жа­ни­ем углеводов: 152. Разделив, по­лу­чим сред­нее зна­че­ние про­дук­тов с со­дер­жа­ни­ем уг­ле­во­дов 0 г: 240,36.

 

Ответ: 1) 118; 2) 240,37.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1310.