СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д17 C1 № 19

В электронную таблицу занесли данные о тестировании учеников. Ниже приведены первые пять строк таблицы:

 

ABCD
1округфамилияпредметбалл
2CУченик 1обществознание246
3ВУченик 2немецкий язык530
4ЮУченик 3русский язык576
5СВУченик 4обществознание304

 

В столбце А записан округ, в котором учится ученик; в столбце В — фамилия; в столбце С — любимый предмет; в столбце D — тестовый балл. Всего в электронную таблицу были занесены данные по 1000 ученикам.

 

Выполните задание.

Откройте файл с данной электронной таблицей. На основании данных, содержащихся в этой таблице, ответьте на два вопроса.

1. Сколько учеников в Восточном округе (В) выбрали в качестве любимого предмета информатику? Ответ на этот вопрос запишите в ячейку Н2 таблицы.

2. Каков средний тестовый балл у учеников Северного округа (С)? Ответ на этот вопрос запишите в ячейку НЗ таблицы с точностью не менее двух знаков после запятой.

 

task19.xls

 

Решение.

task19.xls

 

1. Запишем в ячейку E2 следующую формулу =ЕСЛИ(A2="В";C2;0) и скопируем ее в диапазон E3:E1001. В ячейку столбца E будет записываться название предмета, если ученик из Восточного округа и «0», если это не так. Применив операцию =ЕСЛИ(E2="информатика";1;0), получим столбец (F): с единицами и нулями. Далее, используем операцию =СУММ(F2:F1001). Получим количество учеников, которые считают своим любимым предметом информатику. Таких 10 человек.

2. Для ответа на второй вопрос используем операцию «ЕСЛИ». Запишем в ячейку G2 следующее выражение: =ЕСЛИ(A2="С";D2;0), в результате применения данной операции к диапазону ячеек G2:G1001, получим столбец, в котором записаны баллы только учеников Северного округа. Сложив значения в ячейках, получим сумму баллов учеников: 56 737. Найдём количество учеников Северного округа с помощью команды =СЧЁТЕСЛИ(A2:A1001;"С"), получим 105. Разделив сумму баллов на количество учеников, получим: 540,352 —  искомый средний балл.

 

Ответ: 1) 10; 2) 540,35.

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1301.