информатика
Математика
Информатика
Английский язык
Немецкий язык
Французcкий язык
Испанский язык
Физика
Химия
Биология
География
Обществознание
Литература
История
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 19

В элек­трон­ную таб­ли­цу за­нес­ли дан­ные о те­сти­ро­ва­нии учеников. Ниже при­ве­де­ны пер­вые пять строк таблицы:

 

ABCD
1округфамилияпредметбалл
2CУченик 1обществознание246
3ВУченик 2немецкий язык530
4ЮУченик 3русский язык576
5СВУченик 4обществознание304

 

В столб­це А за­пи­сан округ, в ко­то­ром учит­ся ученик; в столб­це В — фамилия; в столб­це С — любимый предмет; в столб­це D — тестовый балл. Всего в элек­трон­ную таб­ли­цу были за­не­се­ны дан­ные по 1000 ученикам.

 

Выполните задание.

Откройте файл с дан­ной элек­трон­ной таблицей. На ос­но­ва­нии данных, со­дер­жа­щих­ся в этой таблице, от­веть­те на два вопроса.

1. Сколько уче­ни­ков в Во­сточ­ном окру­ге (В) вы­бра­ли в ка­че­стве лю­би­мо­го пред­ме­та информатику? Ответ на этот во­прос за­пи­ши­те в ячей­ку Н2 таблицы.

2. Каков сред­ний те­сто­вый балл у уче­ни­ков Се­вер­но­го окру­га (С)? Ответ на этот во­прос за­пи­ши­те в ячей­ку НЗ таб­ли­цы с точ­но­стью не менее двух зна­ков после запятой.

 

task19.xls

 

Пояснение.

task19.xls

 

1. За­пи­шем в ячей­ку E2 сле­ду­ю­щую фор­му­лу =ЕСЛИ(A2="В";C2;0) и ско­пи­ру­ем ее в диа­па­зон E3:E1001. В ячей­ку столб­ца E будет за­пи­сы­вать­ся на­зва­ние предмета, если уче­ник из Во­сточ­но­го окру­га и «0», если это не так. При­ме­нив опе­ра­цию =ЕСЛИ(E2="информатика";1;0), по­лу­чим стол­бец (F): с еди­ни­ца­ми и нулями. Далее, ис­поль­зу­ем опе­ра­цию =СУММ(F2:F1001). По­лу­чим ко­ли­че­ство учеников, ко­то­рые счи­та­ют своим лю­би­мым пред­ме­том информатику. Таких 10 человек.

2. Для от­ве­та на вто­рой во­прос ис­поль­зу­ем опе­ра­цию «ЕСЛИ». За­пи­шем в ячей­ку G2 сле­ду­ю­щее выражение: =ЕСЛИ(A2="С";D2;0), в ре­зуль­та­те при­ме­не­ния дан­ной опе­ра­ции к диа­па­зо­ну ячеек G2:G1001, по­лу­чим столбец, в ко­то­ром за­пи­са­ны баллы толь­ко уче­ни­ков Се­вер­но­го округа. Сло­жив зна­че­ния в ячейках, по­лу­чим сумму бал­лов учеников: 56 737. Найдём ко­ли­че­ство уче­ни­ков Се­вер­но­го окру­га с по­мо­щью ко­ман­ды =СЧЁТЕСЛИ(A2:A1001;"С"), по­лу­чим 105. Раз­де­лив сумму бал­лов на ко­ли­че­ство учеников, получим: 540,352 —  ис­ко­мый сред­ний балл.

 

Ответ: 1) 10; 2) 540,35.

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1301.