СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д9 № 189

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 0

FOR k = 8 TO 12

    s = s + 12

NEXT k

PRINT s

s = 0

for k in range(8,13):

    s = s + 12

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 0;

    for k := 8 to 12 do

        s := s + 12;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 8 до 12

      s := s + 12

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 8; k <= 12; k++)

          s += 12;

     cout << s;

     return 0;

}

 

Решение.

Цикл «for k := 8 to 12 do» вы­пол­ня­ет­ся пять раз. Каж­дый раз пе­ре­мен­ная s уве­ли­чи­ва­ет­ся на 12. По­сколь­ку изначально s = 0, после вы­пол­не­ния программы по­лу­чим: s = 5 · 12 = 60.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1310.