СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 169

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 0

FOR k = 7 TO 11

    s = s + 11

NEXT k

PRINT s

s = 0

for k in range(7,12):

    s = s + 11

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 0;

    for k := 7 to 11 do

        s := s + 11;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 7 до 11

      s := s + 11

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 7; k <= 11; k++)

          s += 11;

     cout << s;

     return 0;

}

 

Пояснение.

Цикл «for k := 7 to 11 do» вы­пол­ня­ет­ся пять раз. Каж­дый раз пе­ре­мен­ная s уве­ли­чи­ва­ет­ся на 11. По­сколь­ку изначально s = 0, после вы­пол­не­ния программы по­лу­чим: s = 5 · 11 = 55.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1309.