СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 15 № 1293

Выберите ОДНО из пред­ло­жен­ных ниже заданий: 20.1 или 20.2.

 

20.1 Ис­пол­ни­тель Робот умеет пе­ре­ме­щать­ся по лабиринту, на­чер­чен­но­му на плоскости, раз­би­той на клетки. Между со­сед­ни­ми (по сторонам) клет­ка­ми может сто­ять стена, через ко­то­рую Робот прой­ти не может.

У Ро­бо­та есть де­вять команд. Че­ты­ре команды — это команды-приказы:

 

вверх вниз влево вправо

 

При вы­пол­не­нии любой из этих ко­манд Робот пе­ре­ме­ща­ет­ся на одну клет­ку соответственно: вверх ↑ вниз ↓, влево ← , впра­во →. Если Робот по­лу­чит ко­ман­ду пе­ре­дви­же­ния сквозь стену, то он разрушится.

Также у Ро­бо­та есть ко­ман­да закрасить, при ко­то­рой за­кра­ши­ва­ет­ся клетка, в ко­то­рой Робот на­хо­дит­ся в на­сто­я­щий момент.

Ещё че­ты­ре команды —  это ко­ман­ды про­вер­ки условий. Эти ко­ман­ды проверяют, сво­бо­ден ли путь для Ро­бо­та в каж­дом из четырёх воз­мож­ных направлений:

 

сверху свободно  снизу свободно  слева свободно  спра­ва свободно

 

Эти ко­ман­ды можно ис­поль­зо­вать вме­сте с усло­ви­ем «если», име­ю­щим сле­ду­ю­щий вид:

 

если условие то

последовательность команд

все

 

Здесь условие — одна из ко­манд про­вер­ки условия. Последовательность команд — это одна или не­сколь­ко любых команд-приказов. Например, для пе­ре­дви­же­ния на одну клет­ку вправо, если спра­ва нет стенки, и за­кра­ши­ва­ния клет­ки можно ис­поль­зо­вать такой алгоритм:

если спра­ва сво­бод­но то

вправо

закрасить

все

 

В одном усло­вии можно ис­поль­зо­вать не­сколь­ко ко­манд про­вер­ки условий, при­ме­няя ло­ги­че­ские связ­ки и, или, не, например:

 

если (справа свободно) и (не снизу свободно) то

вправо

все

 

Для по­вто­ре­ния по­сле­до­ва­тель­но­сти ко­манд можно ис­поль­зо­вать цикл «пока», име­ю­щий сле­ду­ю­щий вид:

 

нц пока условие

последовательность команд

кц

 

Например, для дви­же­ния вправо, пока это возможно, можно ис­поль­зо­вать сле­ду­ю­щий алгоритм:

 

нц пока спра­ва сво­бод­но

вправо

кц

 

Выполните задание.

 

На бес­ко­неч­ном поле есть го­ри­зон­таль­ная и вер­ти­каль­ная стены. Левый конец го­ри­зон­таль­ной стены соединён с ниж­ним кон­цом вер­ти­каль­ной стены. Длины стен неизвестны. В вер­ти­каль­ной стене есть ровно один проход, точ­ное место про­хо­да и его ши­ри­на неизвестны. Робот на­хо­дит­ся в клетке, рас­по­ло­жен­ной не­по­сред­ствен­но над го­ри­зон­таль­ной сте­ной у её пра­во­го конца. На ри­сун­ке ука­зан один из воз­мож­ных спо­со­бов рас­по­ло­же­ния стен и Ро­бо­та (Робот обо­зна­чен бук­вой «Р»).

 

Напишите для Ро­бо­та алгоритм, за­кра­ши­ва­ю­щий все клетки, рас­по­ло­жен­ные над ниж­ним го­ри­зон­таль­ным от­рез­ком стены. Робот дол­жен за­кра­сить толь­ко клетки, удо­вле­тво­ря­ю­щие дан­но­му условию. Например, для приведённого спра­ва ри­сун­ка Робот дол­жен за­кра­сить сле­ду­ю­щие клет­ки (см. рисунок).

 

 

Конечное рас­по­ло­же­ние Ро­бо­та может быть произвольным. При ис­пол­не­нии ал­го­рит­ма Робот не дол­жен разрушиться. Ал­го­ритм дол­жен ре­шать за­да­чу для про­из­воль­но­го раз­ме­ра поля и лю­бо­го до­пу­сти­мо­го рас­по­ло­же­ния стен.

 

Алгоритм может быть вы­пол­нен в среде фор­маль­но­го ис­пол­ни­те­ля или за­пи­сан в тек­сто­вом редакторе.

 

 

 

 

 

 

 

20.2 На­пи­ши­те программу, ко­то­рая в по­сле­до­ва­тель­но­сти на­ту­раль­ных чисел опре­де­ля­ет ми­ни­маль­ное число, окан­чи­ва­ю­ще­е­ся на 4. Про­грам­ма по­лу­ча­ет на вход ко­ли­че­ство чисел в последовательности, а затем сами числа. В по­сле­до­ва­тель­но­сти все­гда име­ет­ся число, окан­чи­ва­ю­ще­е­ся на 4. Ко­ли­че­ство чисел не пре­вы­ша­ет 1000. Введённые числа не пре­вы­ша­ют 30 000. Про­грам­ма долж­на вы­ве­сти одно число — ми­ни­маль­ное число,

оканчивающееся на 4.

 

Пример ра­бо­ты программы:

 

Входные данныеВыходные данные

3

24

14

34

14

Решение.

20.1 Ко­ман­ды ис­пол­ни­те­ля будем за­пи­сы­вать жир­ным шрифтом, а комментарии, по­яс­ня­ю­щие ал­го­ритм и не яв­ля­ю­щи­е­ся его частью, —курсивом. На­ча­ло ком­мен­та­рия будем обо­зна­чать сим­во­лом «|».

 

||Двигаемся влево, пока не дойдём до вер­ти­каль­ной стены.

нц пока слева свободно

влево

кц

 

|Двигаемся вверх, пока не дойдём до про­хо­да в стене, и за­кра­ши­ва­ем клетки.

нц пока не слева свободно

закрасить

вверх

кц

 

|Двигаемся даль­ше до вер­ти­каль­ной стены.

нц пока слева свободно

вверх

кц

 

|Двигаемся вверх до конца стены и за­кра­ши­ва­ем клетки.

нц пока не слева свободно

закрасить

вверх

кц

 

|Обходим стену.

влево

вниз

 

|Двигаемся вниз, пока не дойдём до про­хо­да в стене, и за­кра­ши­ва­ем клетки.

нц пока не спра­ва свободно

закрасить

вниз

кц

 

|Двигаемся даль­ше до вер­ти­каль­ной стены.

нц пока спра­ва свободно

вниз

кц

 

|Двигаемся вниз до конца стены и за­кра­ши­ва­ем клетки.

нц пока не спра­ва свободно

закрасить

вниз

кц

 

Возможны и дру­гие ва­ри­ан­ты решения. До­пус­ка­ет­ся ис­поль­зо­ва­ние иного син­так­си­са ин­струк­ций исполнителя,

более при­выч­но­го для учащихся. До­пус­ка­ет­ся на­ли­чие от­дель­ных син­так­си­че­ских ошибок, не ис­ка­жа­ю­щих за­мыс­ла ав­то­ра решения

 

20.2 Ре­ше­ни­ем яв­ля­ет­ся программа, за­пи­сан­ная на любом языке программирования. При­мер вер­но­го решения, за­пи­сан­но­го на языке Паскаль:

 

var n,i,a,min: integer;

begin

readln(n);

min := 30001;

for i := 1 to n do

begin

readln(a);

if (a mod 10 = 4) and (a < min)

then min := a;

end;

writeln(min)

end.

 

Возможны и дру­гие ва­ри­ан­ты решения. Для про­вер­ки пра­виль­но­сти ра­бо­ты про­грам­мы не­об­хо­ди­мо ис­поль­зо­вать сле­ду­ю­щие тесты:

 

Входные данныеВыходные данные
1

3

2

4

19

4
2

23

14

24

44

14
3

13

24

44

4

4

 

 

----------

Дублирует за­да­ние 983.

Источник: Де­мон­стра­ци­он­ная вер­сия ГИА—2016.