СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 15 № 1293

Выберите ОДНО из предложенных ниже заданий: 20.1 или 20.2.

 

20.1 Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может.

У Робота есть девять команд. Четыре команды — это команды-приказы:

 

вверх вниз влево вправо

 

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑ вниз ↓, влево ← , вправо →. Если Робот получит команду передвижения сквозь стену, то он разрушится.

Также у Робота есть команда закрасить, при которой закрашивается клетка, в которой Робот находится в настоящий момент.

Ещё четыре команды —  это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений:

 

сверху свободно  снизу свободно  слева свободно  справа свободно

 

Эти команды можно использовать вместе с условием «если», имеющим следующий вид:

 

если условие то

последовательность команд

все

 

Здесь условие — одна из команд проверки условия. Последовательность команд — это одна или несколько любых команд-приказов. Например, для передвижения на одну клетку вправо, если справа нет стенки, и закрашивания клетки можно использовать такой алгоритм:

если справа свободно то

вправо

закрасить

все

 

В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:

 

если (справа свободно) и (не снизу свободно) то

вправо

все

 

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

 

нц пока условие

последовательность команд

кц

 

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

 

нц пока справа свободно

вправо

кц

 

Выполните задание.

 

На бесконечном поле есть горизонтальная и вертикальная стены. Левый конец горизонтальной стены соединён с нижним концом вертикальной стены. Длины стен неизвестны. В вертикальной стене есть ровно один проход, точное место прохода и его ширина неизвестны. Робот находится в клетке, расположенной непосредственно над горизонтальной стеной у её правого конца. На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).

 

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные над нижним горизонтальным отрезком стены. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого справа рисунка Робот должен закрасить следующие клетки (см. рисунок).

 

 

Конечное расположение Робота может быть произвольным. При исполнении алгоритма Робот не должен разрушиться. Алгоритм должен решать задачу для произвольного размера поля и любого допустимого расположения стен.

 

Алгоритм может быть выполнен в среде формального исполнителя или записан в текстовом редакторе.

 

 

 

 

 

 

 

20.2 Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — минимальное число,

оканчивающееся на 4.

 

Пример работы программы:

 

Входные данныеВыходные данные

3

24

14

34

14

Решение.

20.1 Команды исполнителя будем записывать жирным шрифтом, а комментарии, поясняющие алгоритм и не являющиеся его частью, —курсивом. Начало комментария будем обозначать символом «|».

 

||Двигаемся влево, пока не дойдём до вертикальной стены.

нц пока слева свободно

влево

кц

 

|Двигаемся вверх, пока не дойдём до прохода в стене, и закрашиваем клетки.

нц пока не слева свободно

закрасить

вверх

кц

 

|Двигаемся дальше до вертикальной стены.

нц пока слева свободно

вверх

кц

 

|Двигаемся вверх до конца стены и закрашиваем клетки.

нц пока не слева свободно

закрасить

вверх

кц

 

|Обходим стену.

влево

вниз

 

|Двигаемся вниз, пока не дойдём до прохода в стене, и закрашиваем клетки.

нц пока не справа свободно

закрасить

вниз

кц

 

|Двигаемся дальше до вертикальной стены.

нц пока справа свободно

вниз

кц

 

|Двигаемся вниз до конца стены и закрашиваем клетки.

нц пока не справа свободно

закрасить

вниз

кц

 

Возможны и другие варианты решения. Допускается использование иного синтаксиса инструкций исполнителя,

более привычного для учащихся. Допускается наличие отдельных синтаксических ошибок, не искажающих замысла автора решения

 

20.2 Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Паскаль:

 

var n,i,a,min: integer;

begin

readln(n);

min := 30001;

for i := 1 to n do

begin

readln(a);

if (a mod 10 = 4) and (a < min)

then min := a;

end;

writeln(min)

end.

 

Возможны и другие варианты решения. Для проверки правильности работы программы необходимо использовать следующие тесты:

 

Входные данныеВыходные данные
1

3

2

4

19

4
2

23

14

24

44

14
3

13

24

44

4

4

 

 

----------

Дублирует задание 983.

Источник: Демонстрационная версия ГИА—2016.