информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 1262

Запишите зна­че­ние пе­ре­ме­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 0

FOR k = 1 TO 11

    s = s + 12

NEXT k

PRINT s

s = 0

for k in range(1,12):

    s = s + 12

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 0;

    for k := 1 to 11 do

        s := s + 12;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 1 до 11

      s := s + 12

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 1; k <= 11; k++)

          s = s + 12;

     cout << s;

     return 0;

}

 

Пояснение.

Цикл «for k:=1 to 11 do» вы­пол­ня­ет­ся одиннадцать раз. Каж­дый раз пе­ре­мен­ная s уве­ли­чи­ва­ет­ся на 12. По­сколь­ку из­на­чаль­но s = 0, после вы­пол­не­ния про­грам­мы по­лу­чим: s = 11 · 12 = 132.

 

Ответ: 132.