информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 1252

В элек­трон­ную таб­ли­цу за­нес­ли дан­ные о ка­ло­рий­но­сти продуктов. Ниже при­ве­де­ны пер­вые пять строк таблицы.

 

1ПродуктЖиры, гБелки, гУглеводы, гКалорийность, Ккал
2Арахис45,226,39,9552
3Арахис жареный522613,4626
4Горох отварной0,810,520,4130
5Горошек зелёный0,258,355

 

В столб­це A за­пи­сан продукт; в столб­це B – со­дер­жа­ние в нём жиров; в столб­це C – со­дер­жа­ние белков; в столб­це D – со­дер­жа­ние уг­ле­во­дов и в столб­це Е – ка­ло­рий­ность этого продукта. Всего в элек­трон­ную таб­ли­цу были за­не­се­ны дан­ные по 1000 продуктам.

 

 

task19.xls

 

Выполните задание.

Откройте файл с дан­ной элек­трон­ной таб­ли­цей (расположение файла Вам со­об­щат ор­га­ни­за­то­ры экзамена). На ос­но­ва­нии данных, со­дер­жа­щих­ся в этой таблице, от­веть­те на два вопроса.

 

1. Сколь­ко про­дук­тов в таб­ли­це со­дер­жат мень­ше 50 г уг­ле­во­дов и мень­ше 50 г белков? За­пи­ши­те число, обо­зна­ча­ю­щее ко­ли­че­ство этих продуктов, в ячей­ку H2 таблицы.

 

2. Ка­ко­ва сред­няя ка­ло­рий­ность про­дук­тов с со­дер­жа­ни­ем жиров менее 1 г? За­пи­ши­те зна­че­ние в ячей­ку H3 таб­ли­цы с точ­но­стью не менее двух зна­ков после запятой.

Пояснение.

Решение для OpenOffice.org Calc и для Microsoft Excel

Первая фор­му­ла ис­поль­зу­ет­ся для рус­ско­языч­ной за­пи­си функций, вто­рая – для англоязычной.

В ячей­ку F2 за­пи­шем формулу

 

=ЕСЛИ(И(D2<50;C2<50);1;0)

=IF(AND(D2<50;C2<50);1;0)

 

Скопируем фор­му­лу во все ячей­ки диа­па­зо­на F3:F1001.

В ячей­ку H2 за­пи­шем формулу

 

=СУММ(F2:F1001)

=SUM(F2:F1001)

 

В ячей­ку H3 за­пи­шем формулу

 

=СУММЕСЛИ(B2:B1001; "<1";E2:E1001)/СЧЁТЕСЛИ(B2:B1001;"<1")

=SUMIF(B2:B1001; "<1";E2:E1001)/COUNTIF(B2:B1001;"<1")

 

Возможны и дру­гие ва­ри­ан­ты решения.

Если за­да­ние вы­пол­не­но правильно, и при вы­пол­не­нии за­да­ния ис­поль­зо­ва­лись файлы, спе­ци­аль­но под­го­тов­лен­ные для про­вер­ки вы­пол­не­ния дан­но­го задания, то долж­ны по­лу­чить­ся сле­ду­ю­щие ответы:

на пер­вый вопрос: 864;

на вто­рой вопрос: 89,45.