СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д17 C1 № 1173

В электронную таблицу занесли данные о калорийности продуктов. Ниже приведены первые пять строк таблицы.

 

АBCDE
1ПродуктЖиры, гБелки, гУглеводы, гКалорийность,

Ккал

2Арахис45,226,39,9552
3Арахис жареный522613,4626
4Горох отварной0,810,520,4130
5Горошек зелёный0,258,355

 

В столбце A записан продукт; в столбце B — содержание в нём жиров; в столбце C — содержание белков; в столбце D — содержание углеводов и в столбце Е — калорийность этого продукта. Всего в электронную таблицу были занесены данные по 1000 продуктам.

 

task19.xls

 

Выполните задание.

Откройте файл с данной электронной таблицей. На основании данных, содержащихся в этой таблице, ответьте на два вопроса.

1. Сколько продуктов в таблице содержат меньше 10 г жиров и меньше 10 г углеводов? Запишите число этих продуктов в ячейку H2 таблицы.

2. Какова средняя калорийность продуктов с содержанием белков менее 1 г? Ответ на этот вопрос запишите в ячейку H3 таблицы с точностью не менее двух знаков после запятой.

Решение.

Решение для OpenOffice.org Calc и для Microsoft Excel

 

В ячейку F2 запишем формулу

=ЕСЛИ(И(B2<10;D2<10);1;0)

=IF(AND(B2<10;D2<10);1;0)

Скопируем формулу во все ячейки диапазона F3:F1001.

 

В ячейку H2 запишем формулу

=СУММ(F2:F1001)

=SUM(F2:F1001)

 

В ячейку H3 запишем формулу

=СУММЕСЛИ(C2:C1001; "<1";E2:E1001)/СЧЁТЕСЛИ(C2:C1001;"<1")

=SUMIF(C2:C1001; "<1";E2:E1001)/COUNTIF(C2:C1001;"<1")

Возможны и другие варианты решения.

Если задание выполнено правильно, и при выполнении задания использовались файлы, специально подготовленные для проверки выполнения данного задания, то должны получиться следующие ответы:

на первый вопрос: 354;

на второй вопрос: 125,41.