СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 1173

В элек­трон­ную таб­ли­цу за­нес­ли дан­ные о ка­ло­рий­но­сти продуктов. Ниже при­ве­де­ны пер­вые пять строк таблицы.

 

АBCDE
1ПродуктЖиры, гБелки, гУглеводы, гКалорийность,

Ккал

2Арахис45,226,39,9552
3Арахис жареный522613,4626
4Горох отварной0,810,520,4130
5Горошек зелёный0,258,355

 

В столб­це A за­пи­сан продукт; в столб­це B — со­дер­жа­ние в нём жиров; в столб­це C — со­дер­жа­ние белков; в столб­це D — со­дер­жа­ние уг­ле­во­дов и в столб­це Е — ка­ло­рий­ность этого продукта. Всего в элек­трон­ную таб­ли­цу были за­не­се­ны дан­ные по 1000 продуктам.

 

task19.xls

 

Выполните задание.

Откройте файл с дан­ной элек­трон­ной таб­ли­цей. На ос­но­ва­нии данных, со­дер­жа­щих­ся в этой таблице, от­веть­те на два вопроса.

1. Сколь­ко про­дук­тов в таб­ли­це со­дер­жат мень­ше 10 г жиров и мень­ше 10 г углеводов? За­пи­ши­те число этих про­дук­тов в ячей­ку H2 таблицы.

2. Ка­ко­ва сред­няя ка­ло­рий­ность про­дук­тов с со­дер­жа­ни­ем бел­ков менее 1 г? Ответ на этот во­прос за­пи­ши­те в ячей­ку H3 таб­ли­цы с точ­но­стью не менее двух зна­ков после запятой.

Пояснение.

Решение для OpenOffice.org Calc и для Microsoft Excel

 

В ячей­ку F2 за­пи­шем формулу

=ЕСЛИ(И(B2<10;D2<10);1;0)

=IF(AND(B2<10;D2<10);1;0)

Скопируем фор­му­лу во все ячей­ки диа­па­зо­на F3:F1001.

 

В ячей­ку H2 за­пи­шем формулу

=СУММ(F2:F1001)

=SUM(F2:F1001)

 

В ячей­ку H3 за­пи­шем формулу

=СУММЕСЛИ(C2:C1001; "<1";E2:E1001)/СЧЁТЕСЛИ(C2:C1001;"<1")

=SUMIF(C2:C1001; "<1";E2:E1001)/COUNTIF(C2:C1001;"<1")

Возможны и дру­гие ва­ри­ан­ты решения.

Если за­да­ние вы­пол­не­но правильно, и при вы­пол­не­нии за­да­ния ис­поль­зо­ва­лись файлы, спе­ци­аль­но под­го­тов­лен­ные для про­вер­ки вы­пол­не­ния дан­но­го задания, то долж­ны по­лу­чить­ся сле­ду­ю­щие ответы:

на пер­вый вопрос: 354;

на вто­рой вопрос: 125,41.