информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 1163

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 0

FOR k = 14 TO 18

    s = s + 7

NEXT k

PRINT s

s = 0

for k in range(14,19):

    s = s + 7

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 0;

    for k := 14 to 18 do

        s := s + 7;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 14 до 18

      s := s + 7

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 14; k <= 18; k++)

          s = s + 7;

     cout << s;

     return 0;

}

 

Пояснение.

Цикл for k := 14 to 18 do вы­пол­нит­ся 5 раз. Каж­дый раз пе­ре­мен­ная s уве­ли­чи­ва­ет­ся на 7. По­сколь­ку из­на­чаль­но зна­че­ние s равно 0, после вы­пол­не­ния про­грам­мы по­лу­чим s = 0 + 7 · 5 = 35.

 

Ответ: 35.