СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 1143

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 100

FOR k = 0 TO 10

    s = s − 5

NEXT k

PRINT s

s = 100

for k in range(11):

    s = s − 5

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 100;

    for k := 0 to 10 do

        s := s − 5;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 100

   нц для k от 0 до 10

      s := s − 5

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 100;

     for (int k = 0; k <= 10; k++)

          s = s − 5;

     cout << s;

     return 0;

}

 

Пояснение.

Цикл for k := 0 to 10 do вы­пол­нит­ся 11 раз. Каж­дый раз пе­ре­мен­ная s умень­ша­ет­ся на 5. По­сколь­ку из­на­чаль­но зна­че­ние s равно 100, после вы­пол­не­ния про­грам­мы по­лу­чим s = 100 − 5 · 11 = 45.

 

Ответ: 45.