СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 14 № 11046

В электронную таблицу занесли данные о тестировании учеников. Ниже приведены первые пять строк таблицы.

 

ABCD
1ОкругФамилияПредметБалл
2СУченик 1Обществознание246
3ВУченик 2Немецкий язык530
4ЮУченик 3Русский язык576
5СВУченик 4Обществознание304

 

В столбце A записан округ, в котором учится ученик; в столбце B — фамилия; в столбце C — любимый предмет; в столбце D — тестовый балл. Всего в электронную таблицу были внесены данные по одной тысяче учеников.

 

Выполните задание.

1. Сколько учеников в Южном округе (Ю) выбрали в качестве любимого предмета английский язык? Ответ на этот вопрос запишите в ячейку H2 таблицы.

2. Каков средний тестовый балл у учеников Юго-Восточного округа (ЮВ)? Ответ на этот вопрос запишите в ячейку H3 таблицы с точностью не менее двух знаков после запятой.

3. Постройте круговую диаграмму, отображающую соотношение учеников из округов «С», «В», «Ю». Левый верхний угол диаграммы разместите вблизи ячейки G6.

 

task 14.xls

 

Решение.

1. Первая формула используется для русскоязычной записи функций, вторая — для англоязычной.

В ячейку Е2 запишем формулу:

 

=ЕСЛИ(A2="Ю";C2;0)

=IF(A2="Ю";C2;0)

 

Скопируем формулу во все ячейки диапазона Е3:Е1001. В ячейку H2 запишем формулу

 

=СЧЁТЕСЛИ(E2:E1001;"английский язык")

=COUNTIF(E2:E1001;"английский язык")

 

2. В ячейку H3 запишем формулу

 

=СУММЕСЛИ(A2:A1001;"ЮВ";D2:D1001)/СЧЁТЕСЛИ(A2:A1001;"ЮВ")

=SUMIF(A2:A1001;"ЮВ";D2:D1001)/COUNTIF(A2:A1001;"ЮВ")

 

Можно использовать формулу

 

=СРЗНАЧЕСЛИ(A2:A1001;"ЮВ";D2:D1001)

 

3. В ячейку J2 вставим формулу =СЧЁТЕСЛИ(A2:A1001; "С"), в ячейку J3 вставим формулу =СЧЁТЕСЛИ(A2:A1001; "В"), в ячейку J4 вставим формулу =СЧЁТЕСЛИ(A2:A1001; "Ю"). Теперь построим по полученным значениям круговую диаграмму, подпишем сектора.

 

Ответ: 1) 12; 2) 516,30.