СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д9 № 1103

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 0

FOR k = 4 TO 9

    s = s + 12

NEXT k

PRINT s

s = 0

for k in range(4,10):

    s = s + 12

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 0;

    for k := 4 to 9 do

        s := s + 12;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 4 до 9

      s := s + 12

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 4; k <= 9; k++)

          s = s + 12;

     cout << s;

     return 0;

}

 

Решение.

Цикл for k := 4 to 9 do вы­пол­нит­ся 6 раз. Каж­дый раз пе­ре­мен­ная s уве­ли­чи­ва­ет­ся на 12. По­сколь­ку из­на­чаль­но зна­че­ние s равно 0, после вы­пол­не­ния про­грам­мы по­лу­чим s = 0 + 6 · 12 = 72.

 

Ответ: 72.