СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д17 C1 № 1090

В электронную таблицу занесли данные о тестировании учеников. Ниже приведены первые пять строк таблицы.

 

ABCD
1ОкругФамилияПредметБалл
2СУченик 1Обществознание246
3ВУченик 2Немецкий язык530
4ЮУченик 3Русский язык576
5СВУченик 4Обществознание304

 

В столбце A записан округ, в котором учится ученик; в столбце B — фамилия; в столбце C — любимый предмет; в столбце D — тестовый балл. Всего в электронную таблицу были внесены данные по одной тысяче учеников.

 

 

task19.xls

 

Выполните задание.

Откройте файл с данной электронной таблицей. На основании данных, содержащихся в этой таблице, ответьте на два вопроса.

 

1. Сколько учеников в Северо-Западном округе (СЗ) выбрали в качестве любимого предмета русский язык? Ответ на этот вопрос запишите в ячейку H2 таблицы.

2. Каков средний тестовый балл у учеников Западного округа (З)? Ответ на этот вопрос запишите в ячейку H3 таблицы с точностью не менее двух знаков после запятой.

Решение.

Решение для OpenOffice.org Calc и для Microsoft Excel

 

Первая формула используется для русскоязычной записи функций, вторая — для англоязычной.

В ячейку Е2 запишем формулу:

 

=ЕСЛИ(A2="СЗ";C2;0)

=IF(A2="СЗ";C2;0)

 

Скопируем формулу во все ячейки диапазона Е3:Е1001. В ячейку H2 запишем формулу

 

=СЧЁТЕСЛИ(E2:E1001;"русский язык")

=COUNTIF(E2:E1001;"русский язык")

 

В ячейку H3 запишем формулу

 

=СУММЕСЛИ(A2:A1001;"З";D2:D1001)/СЧЁТЕСЛИ(A2:A1001;"З")

=SUMIF(A2:A1001;"З";D2:D1001)/COUNTIF(A2:A1001;"З")

 

Возможны и другие варианты решения.

Если задание выполнено правильно и при выполнении задания использовались файлы, специально подготовленные для проверки выполнения данного задания, то должны получиться следующие ответы: на первый вопрос: 11; на второй вопрос: 535,25.