информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 1070

В элек­трон­ную таб­ли­цу за­нес­ли дан­ные о те­сти­ро­ва­нии учеников. Ниже при­ве­де­ны пер­вые пять строк таблицы.

 

ABCD
1ОкругФамилияПредметБалл
2СУченик 1Обществознание246
3ВУченик 2Немецкий язык530
4ЮУченик 3Русский язык576
5СВУченик 4Обществознание304

 

В столб­це A за­пи­сан округ, в ко­то­ром учит­ся ученик; в столб­це B — фамилия; в столб­це C — лю­би­мый предмет; в столб­це D — те­сто­вый балл. Всего в элек­трон­ную таб­ли­цу были вне­се­ны дан­ные по одной ты­ся­че учеников.

 

 

task19.xls

 

Выполните задание.

Откройте файл с дан­ной элек­трон­ной таб­ли­цей. На ос­но­ва­нии данных, со­дер­жа­щих­ся в этой таблице, от­веть­те на два вопроса.

 

1. Сколь­ко уче­ни­ков в Южном окру­ге (Ю) вы­бра­ли в ка­че­стве лю­би­мо­го пред­ме­та ан­глий­ский язык? Ответ на этот во­прос за­пи­ши­те в ячей­ку H2 таблицы.

2. Каков сред­ний те­сто­вый балл у уче­ни­ков Юго-Восточного окру­га (ЮВ)? Ответ на этот во­прос за­пи­ши­те в ячей­ку H3 таб­ли­цы с точ­но­стью не менее двух зна­ков после запятой.

Пояснение.

Решение для OpenOffice.org Calc и для Microsoft Excel

 

Первая фор­му­ла ис­поль­зу­ет­ся для рус­ско­языч­ной за­пи­си функций, вто­рая — для англоязычной.

В ячей­ку Е2 за­пи­шем формулу:

 

=ЕСЛИ(A2="Ю";C2;0)

=IF(A2="Ю";C2;0)

 

Скопируем фор­му­лу во все ячей­ки диа­па­зо­на Е3:Е1001. В ячей­ку H2 за­пи­шем формулу

 

=СЧЁТЕСЛИ(E2:E1001;"английский язык")

=COUNTIF(E2:E1001;"английский язык")

 

В ячей­ку H3 за­пи­шем формулу

 

=СУММЕСЛИ(A2:A1001;"ЮВ";D2:D1001)/СЧЁТЕСЛИ(A2:A1001;"ЮВ")

=SUMIF(A2:A1001;"ЮВ";D2:D1001)/COUNTIF(A2:A1001;"ЮВ")

 

Возможны и дру­гие ва­ри­ан­ты решения.

Если за­да­ние вы­пол­не­но пра­виль­но и при вы­пол­не­нии за­да­ния ис­поль­зо­ва­лись файлы, спе­ци­аль­но под­го­тов­лен­ные для про­вер­ки вы­пол­не­ния дан­но­го задания, то долж­ны по­лу­чить­ся сле­ду­ю­щие ответы: на пер­вый вопрос: 12; на вто­рой вопрос: 516, 30.