СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 1060

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 0

FOR k = 3 TO 10

    s = s + 13

NEXT k

PRINT s

s = 0

for k in range(3,11):

    s = s + 13

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 0;

    for k := 3 to 10 do

        s := s + 13;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 3 до 10

      s := s + 13

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 3; k <= 10; k++)

          s = s + 13;

     cout << s;

     return 0;

}

 

Пояснение.

Цикл for i := 3 to 10 do вы­пол­нит­ся 8 раз. Каж­дый раз пе­ре­мен­ная s уве­ли­чи­ва­ет­ся на 13. По­сколь­ку из­на­чаль­но зна­че­ние s равно 0, после вы­пол­не­ния про­грам­мы по­лу­чим s = 8 · 13 = 104.

 

Ответ: 104.