СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 14 № 10566

В электронную таблицу занесли данные о тестировании учеников по выбранным ими предметам.

 

ABCD
1округфамилияпредметбалл
2CУченик 1Физика240
3ВУченик 2Физкультура782
4ЮУченик 3Биология361
5СВУченик 4Обществознание377

 

В столбце A записан код округа, в котором учится ученик; в столбце B — фамилия, в столбце C — выбранный учеником предмет; в столбце D — тестовый балл. Всего в электронную таблицу были занесены данные по 1000 учеников.

 

Выполните задание.

Откройте файл с данной электронной таблицей. На основании данных, содержащихся в этой таблице, ответьте на два вопроса.

1. Определите, сколько учеников, которые проходили тестирование по информатике, набрали более 600 баллов. Ответ запишите в ячейку H2 таблицы.

2. Найдите средний тестовый балл учеников, которые проходили тестирование по информатике. Ответ запишите в ячейку H3 таблицы с точностью не менее двух знаков после запятой.

3. Постройте круговую диаграмму, отображающую соотношение числа участников из округов с кодами «В», «Зел» и «З». Левый верхний угол диаграммы разместите вблизи ячейки G6.

 

task 14.xls

 

Решение.

1. Запишем в ячейку E2 следующую формулу =ЕСЛИ(И(D2>600; C2="информатика");D2;0) и скопируем ее в диапазон E3:E1001. Применив операцию =ЕСЛИ(E2>0;1;0), получим столбец (F): с единицами и нулями. Далее, используем операцию =СУММ(F2:F1001). Получим количество учеников, которые проходили тестирование по информатике и набрали более 600 баллов. Таких 32 человека.

2. Для ответа на второй вопрос используем операцию «ЕСЛИ». Запишем в ячейку G2 следующее выражение: =ЕСЛИ(C2="информатика"; D2;0), в результате применения данной операции к диапазону ячеек G2:G1001, получим столбец, в котором записаны баллы только учеников, сдававших информатику. Сложив значения в ячейках, получим сумму баллов учеников: 39 371. Найдём количество учеников, сдававших информатику, с помощью команды =СЧЁТЕСЛИ(C2:C1001;"информатика"), получим 72. Разделив сумму баллов на количество учеников, получим: 546,8194 —  искомый средний балл.

3. В ячейку J2 вставим формулу =СЧЁТЕСЛИ(A2:A1001; "В"), в ячейку J3 вставим формулу =СЧЁТЕСЛИ(A2:A1001; "Зел"), в ячейку J4 вставим формулу =СЧЁТЕСЛИ(A2:A1001; "З"). Теперь построим по полученным значениям круговую диаграмму, подпишем сектора.

 

Ответ: 1) 32; 2) 546,82.