СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 1040

Запишите зна­че­ние пе­ре­мен­ной u, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM u, i AS INTEGER

u = 26

FOR i = 1 TO 5

    u = u − i

NEXT i

PRINT u

u = 26

for i in range(1,6):

    u = u − i

print (u)

ПаскальАлгоритмический язык

var u, i: integer;

begin

    u := 26;

    for i := 1 to 5 do

        u := u − i;

    writeln(u);

end.

алг

нач

   цел u, i

   u := 26;

   нц для i от 1 до 5

      u := u − i

   кц

   вывод u

кон

С++

#include <iostream>

using namespace std;

int main() {

    int u = 26;

    for (int i = 1; i <= 5; i++)

         u = u − i;

    cout << u;

    return 0;

}

 

Пояснение.

Цикл for i := 1 to 5 do вы­пол­нит­ся 5 раз. Каж­дый раз пе­ре­мен­ная u умень­ша­ет­ся на i. По­сколь­ку из­на­чаль­но зна­че­ние u равно 26, после вы­пол­не­ния про­грам­мы по­лу­чим u = 26 − 1 − 2 − 3 − 4 − 5 = 11.

 

Ответ: 11.