СДАМ ГИА






Каталог заданий. Задания 10. Циклический алгоритм обработки массива чисел, записанный на алгоритмическом языке
Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 10 № 10

В таб­ли­це Dat хра­нят­ся дан­ные из­ме­ре­ний сред­не­су­точ­ной тем­пе­ра­ту­ры за 10 дней в гра­ду­сах (Dat[1] — дан­ные за пер­вый день, Dat[2] — за вто­рой и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел к, m

Dat[1] := 12

Dat[2] := 15

Dat[3] := 17

Dat[4] := 15

Dat[5] := 14

Dat[6] := 12

Dat[7] := 10

Dat[8] := 13

Dat[9] := 14

Dat[10] := 15

m := 0

нц для к от 1 до 10

если Dat[к]=15 то

m : = m+1

все

КЦ

вывод m

КОН

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1)= 12: Dat(2) = 15

Dat(3) = 17: Dat(4) = 15

Dat(5) = 14: Dat(6) = 12

Dat(7) = 10: Dat(8) = 13

Dat(9) = 14: Dat(10) = 15

m = 0

FOR k = 1 TO 10

IF Dat(k)=15 THEN

m = m+1

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

Dat[1] := 12; Dat[2] := 15;

Dat[3] := 17; Dat[4] := 15;

Dat[5] := 14; Dat[6] := 12;

Dat[7] := 10; Dat[8] := 13;

Dat[9] := 14; Dat[10] := 15;

m := 0;

for k := 1 to 10 do

if Dat[k] = 15 then

begin

m := m+1;

end;

writeln(m);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1301.

2
Задание 10 № 30

В таб­ли­це Dat хра­нят­ся дан­ные из­ме­ре­ний сред­не­су­точ­ной тем­пе­ра­ту­ры за 10 дней в гра­ду­сах (Dat[1] — дан­ные за пер­вый день, Dat[2] — за вто­рой и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел к, m

Dat[1] := 12

Dat[2] := 15

Dat[3] := 17

Dat[4] := 15

Dat[5] := 14

Dat[6] := 12

Dat[7] := 10

Dat[8] := 13

Dat[9] := 14

Dat[10] := 15

m := 0

нц для к от 1 до 10

если Dat[к] > m то

m : = Dat[к]

все

КЦ

вывод m

КОН

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 12: Dat(2) = 15

Dat(3) = 17: Dat(4) = 15

Dat(5) = 14: Dat(6) = 12

Dat(7) = 10: Dat(8) = 13

Dat(9) = 14: Dat(10) = 15

m = 0

FOR k := 1 TO 10

IF Dat(k) > m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

Dat[1] := 12; Dat[2] := 15;

Dat[3] := 17; Dat[4] := 15;

Dat[5] := 14; Dat[6] := 12;

Dat[7] := 10; Dat[8] := 13;

Dat[9] := 14; Dat[10] := 15;

m := 0;

for k := 1 to 10 do

if Dat[k] > m then

begin

m := Dat[k]

end;

writeln(m);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1302.

3
Задание 10 № 50

В таб­ли­це Dat хра­нят­ся дан­ные из­ме­ре­ний сред­не­су­точ­ной тем­пе­ра­ту­ры за 10 дней в гра­ду­сах (Dat[1] — дан­ные за пер­вый день, Dat[2] — за вто­рой и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел к, m

Dat[1] := 12

Dat[2] := 15

Dat[3] := 17

Dat[4] := 15

Dat[5] := 14

Dat[6] := 12

Dat[7] := 10

Dat[8] := 13

Dat[9] := 14

Dat[10] := 15

m := 20

нц для к от 1 до 10

если Dat[k] < m то

m : = Dat[k]

все

КЦ

вывод m

КОН

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 12: Dat(2) = 15

Dat(3) = 17: Dat(4) = 15

Dat(5) = 14: Dat(6) = 12

Dat(7) = 10: Dat(8) = 13

Dat(9) = 14: Dat(10) = 15

m = 20

FOR k := 1 TO 10

IF Dat(k) < m THEN

m = Dat[k]

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1...10] of integer;

Begin

Dat[1] := 12; Dat[2] := 15;

Dat[3] := 17; Dat[4] := 15;

Dat[5] := 14; Dat[6] := 12;

Dat[7] := 10; Dat[8] := 13;

Dat[9] := 14; Dat[10] := 15;

m := 20;

for k := 1 to 10 do

if Dat[k] < m then

begin

m := Dat[k]

end;

writeln(m);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1303.

4
Задание 10 № 70

В таб­ли­це Dat хра­нят­ся дан­ные из­ме­ре­ний сред­не­су­точ­ной тем­пе­ра­ту­ры за 10 дней в гра­ду­сах (Dat[1] — дан­ные за пер­вый день, Dat[2] — за вто­рой и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел к, m

Dat[1] := 12

Dat[2] := 15

Dat[3] := 17

Dat[4] := 15

Dat[5] := 14

Dat[6] := 12

Dat[7] := 10

Dat[8] := 13

Dat[9] := 14

Dat[10] := 15

m := 0

нц для к от 1 до 10

если Dat[к] > 12 то

m : = m + 1

все

КЦ

вывод m

КОН

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 12: Dat(2) = 15

Dat(3) = 17: Dat(4) = 15

Dat(5) = 14: Dat(6) = 12

Dat(7) = 10: Dat(8) = 13

Dat(9) = 14: Dat(10) = 15

m = 0

FOR k := 1 TO 10

IF Dat(k) > 12 THEN

m = m + 1

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

Dat[1] := 12; Dat[2] := 15;

Dat[3] := 17; Dat[4] := 15;

Dat[5] := 14; Dat[6] := 12;

Dat[7] := 10; Dat[8] := 13;

Dat[9] := 14; Dat[10] := 15;

m := 0;

for k := 1 to 10 do

if Dat[k] > 12 then

begin

m := m + 1

end;

writeln(m);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1304.

5
Задание 10 № 90

В таб­ли­це Dat хра­нят­ся дан­ные из­ме­ре­ний сред­не­су­точ­ной тем­пе­ра­ту­ры за 10 дней в гра­ду­сах (Dat[1] — дан­ные за пер­вый день, Dat[2] — за вто­рой и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел к, m

Dat[1] := 2

Dat[2] := 5

Dat[3] := 8

Dat[4] := 5

Dat[5] := 4

Dat[6] := 2

Dat[7] := 0

Dat[8] := 3

Dat[9] := 4

Dat[10] := 5

m := 0

нц для к от 1 до 10

если Dat[к] > m то

m : = Dat[к]

все

КЦ

вывод m

КОН

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 2: Dat(2) = 5

Dat(3) = 8: Dat(4) = 5

Dat(5) = 4: Dat(6) = 2

Dat(7) = 0: Dat(8) = 3

Dat(9) = 4: Dat(10) = 5

m = 0

FOR k := 1 TO 10

IF Dat(k)>m THEN

m = Dat[k]

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1...10] of integer;

Begin

Dat[1] := 2; Dat[2] := 5;

Dat[3] := 8; Dat[4] := 5;

Dat[5] := 4; Dat[6] := 2;

Dat[7] := 0; Dat[8] := 3;

Dat[9] := 4; Dat[10] := 5;

m := 0;

for k := 1 to 10 do

if Dat[k] > m then

begin

m := Dat[k]

end;

writeln(m);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Сибирь, Даль­ний Восток. Вариант 1305.

6
Задание 10 № 110

В таб­ли­це Dat хра­нят­ся дан­ные из­ме­ре­ний сред­не­су­точ­ной тем­пе­ра­ту­ры за 10 дней в гра­ду­сах (Dat[1] — дан­ные за пер­вый день, Dat[2] — за вто­рой и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел к, m

Dat[1] := 2

Dat[2] := 5

Dat[3] := 7

Dat[4] := 5

Dat[5] := 4

Dat[6] := 2

Dat[7] := 0

Dat[8] := 3

Dat[9] := 4

Dat[10] := 5

m := 10

нц для к от 1 до 10

если Dat[к] < m то

m : = Dat[к]

все

КЦ

вывод m

КОН

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 2: Dat(2) = 5

Dat(3) = 7: Dat(4) = 5

Dat(5) = 4: Dat(6) = 2

Dat(7) = 0: Dat(8) = 3

Dat(9) = 4: Dat(10) = 5

m = 10

FOR k := 1 TO 10

IF Dat(k) < m THEN

m = Dat[k]

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1...10] of integer;

Begin

Dat[1] := 2; Dat[2] := 5;

Dat[3] := 7; Dat[4] := 5;

Dat[5] := 4; Dat[6] := 2;

Dat[7] := 0; Dat[8] := 3;

Dat[9] := 4; Dat[10] := 5;

m := 10;

for k := 1 to 10 do

if Dat [ k] < m then

begin

m := Dat[k]

end;

writeln(m);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Сибирь, Даль­ний Восток. Вариант 1306.

7
Задание 10 № 130

В таб­ли­це Dat хра­нят­ся дан­ные из­ме­ре­ний сред­не­су­точ­ной тем­пе­ра­ту­ры за 10 дней в гра­ду­сах (Dat[1] — дан­ные за пер­вый день, Dat[2] — за вто­рой и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел к, m

Dat[1] := 2

Dat[2] := 5

Dat[3] := 7

Dat[4] := 5

Dat[5] := 4

Dat[6] := 2

Dat[7] := 0

Dat[8] := 2

Dat[9] := 4

Dat[10] := 5

m := 0

нц для к от 1 до 10

если Dat[к] > 3 то

m : = m+1

все

КЦ

вывод m

КОН

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 2: Dat(2) = 5

Dat(3) = 7: Dat(4) = 5

Dat(5) = 4: Dat(6) = 2

Dat(7) = 0: Dat(8) = 2

Dat(9) = 4: Dat(10) = 5

m = 0

FOR k := 1 TO 10

IF Dat(k) > 3 THEN

m =m+1

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

Dat[1] := 2; Dat[2] := 5;

Dat[3] := 7; Dat[4] := 5;

Dat[5] := 4; Dat[6] := 2;

Dat[7] := 0; Dat[8] := 2;

Dat[9] := 4; Dat[10] := 5;

m := 0;

for k := 1 to 10 do

if Dat[k] > 3 then

begin

m := m+1

end;

writeln(m);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Сибирь, Даль­ний Восток. Вариант 1307.

8
Задание 10 № 150

В таб­ли­це Dat пред­став­ле­ны дан­ные о ко­ли­че­стве голосов, по­дан­ных за 10 ис­пол­ни­те­лей на­род­ных песен (Dat[1] — ко­ли­че­ство голосов, по­дан­ных за пер­во­го исполнителя, Dat[2] — за вто­ро­го и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел к, m

Dat[1] := 56

Dat[2] := 70

Dat[3] := 20

Dat[4] := 41

Dat[5] := 14

Dat[6] := 22

Dat[7] := 30

Dat[8] := 12

Dat[9] := 65

Dat[10] := 35

m := 0

нц для к от 1 до 10

если Dat[к] > 25 то

m : = m+1

все

КЦ

вывод m

КОН

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 56: Dat(2) = 70

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 22

Dat(7) = 30: Dat(8) = 12

Dat(9) = 65: Dat(10) = 35

m = 0

FOR k := 1 TO 10

IF Dat(k) > 25 THEN

m =m+1

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1...10] of integer;

Begin

Dat[1] := 56; Dat[2] := 70;

Dat[3] := 20; Dat[4] := 41;

Dat[5] := 14; Dat[6] := 22;

Dat[7] := 30; Dat[8] := 12;

Dat[9] := 65; Dat[10] := 35;

m := 0;

for k := 1 to 10 do

if Dat[k] > 25 then

begin

m := m+1

end;

writeln(m);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1308.

9
Задание 10 № 170

В таб­ли­це Dat пред­став­ле­ны дан­ные о ко­ли­че­стве голосов, по­дан­ных за 10 ис­пол­ни­те­лей на­род­ных песен (Dat[1] — ко­ли­че­ство голосов, по­дан­ных за пер­во­го исполнителя, Dat[2] — за вто­ро­го и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел к, m

Dat[1] := 56

Dat[2] := 70

Dat[3] := 20

Dat[4] := 41

Dat[5] := 14

Dat[6] := 22

Dat[7] := 30

Dat[8] := 12

Dat[9] := 65

Dat[10] := 35

m := 0

нц для к от 1 до 10

если Dat[к] < 35 то

m : = m+1

все

КЦ

вывод m

КОН

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 56: Dat(2) = 70

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 22

Dat(7) = 30: Dat(8) = 12

Dat(9) = 65: Dat(10) = 35

m = 0

FOR k := 1 TO 10

IF Dat(k) < 35 THEN

m =m+1

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

Dat[1] := 56; Dat[2] := 70;

Dat[3] := 20; Dat[4] := 41;

Dat[5] := 14; Dat[6] := 22;

Dat[7] := 30; Dat[8] := 12;

Dat[9] := 65; Dat[10] := 35;

m := 0;

for k := 1 to 10 do

if Dat[k] < 35 then

begin

m := m+1

end;

writeln(m);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1309.

10
Задание 10 № 190

В таб­ли­це Dat пред­став­ле­ны дан­ные о ко­ли­че­стве голосов, по­дан­ных за 10 ис­пол­ни­те­лей на­род­ных песен (Dat[1] — ко­ли­че­ство голосов, по­дан­ных за пер­во­го исполнителя, Dat[2] — за вто­ро­го и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел к, m

Dat[1] := 56

Dat[2] := 70

Dat[3] := 20

Dat[4] := 41

Dat[5] := 14

Dat[6] := 22

Dat[7] := 30

Dat[8] := 12

Dat[9] := 65

Dat[10] := 35

m := 100

нц для к от 1 до 10

если Dat[к] < m то

m : = Dat[к]

все

КЦ

вывод m

КОН

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 56: Dat(2) = 70

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 22

Dat(7) = 30: Dat(8) = 12

Dat(9) = 65: Dat(10) = 35

m = 100

FOR k := 1 TO 10

IF Dat(k) < m THEN

m =Dat(k)

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1...10] of integer;

Begin

Dat[1] := 56; Dat[2] := 70;

Dat[3] := 20; Dat[4] := 41;

Dat[5] := 14; Dat[6] := 22;

Dat[7] := 30; Dat[8] := 12;

Dat[9] := 65; Dat[10] := 35;

m := 100;

for k := 1 to 10 do

if Dat[k] < m then

begin

m := Dat[k]

end;

writeln(m);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1310.

11
Задание 10 № 210

В таб­ли­це Dat пред­став­ле­ны дан­ные о ко­ли­че­стве голосов, по­дан­ных за 10 ис­пол­ни­те­лей на­род­ных песен (Dat[1] — ко­ли­че­ство голосов, по­дан­ных за пер­во­го исполнителя, Dat[2] — за вто­ро­го и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел к, m

Dat[1] := 56

Dat[2] := 70

Dat[3] := 20

Dat[4] := 41

Dat[5] := 14

Dat[6] := 22

Dat[7] := 30

Dat[8] := 12

Dat[9] := 65

Dat[10] := 35

m := 0

нц для к от 1 до 10

если Dat[к] > m то

m : = Dat[к]

все

КЦ

вывод m

КОН

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 56: Dat(2) = 70

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 22

Dat(7) = 30: Dat(8) = 12

Dat(9) = 65: Dat(10) = 35

m = 0

FOR k := 1 TO 10

IF Dat(k) > m THEN

m =Dat(k)

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1...10] of integer;

Begin

Dat[1] := 56; Dat[2] := 70;

Dat[3] := 20; Dat[4] := 41;

Dat[5] := 14; Dat[6] := 22;

Dat[7] := 30; Dat[8] := 12;

Dat[9] := 65; Dat[10] := 35;

m := 0;

for k := 1 to 10 do

if Dat[k] > m then

begin

m := Dat[k]

end;

writeln(m);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1311.

12
Задание 10 № 230

В таб­ли­це Dat пред­став­ле­ны дан­ные о ко­ли­че­стве голосов, по­дан­ных за 10 ис­пол­ни­те­лей на­род­ных песен (Dat[1] — ко­ли­че­ство голосов, по­дан­ных за пер­во­го исполнителя, Dat[2] — за вто­ро­го и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел к, m

Dat[1] := 16

Dat[2] := 20

Dat[3] := 20

Dat[4] := 41

Dat[5] := 14

Dat[6] := 21

Dat[7] := 28

Dat[8] := 12

Dat[9] := 15

Dat[10] := 35

m := 0

нц для к от 1 до 10

если Dat[к] < 25 то

m : = m+1

все

КЦ

вывод m

КОН

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 16: Dat(2) = 20

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 21

Dat(7) = 28: Dat(8) = 12

Dat(9) = 15: Dat(10) = 35

m = 0

FOR k := 1 TO 10

IF Dat(k) < 25 THEN

m =m+1

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1...10] of integer;

Begin

Dat[1] := 16; Dat[2] := 20;

Dat[3] := 20; Dat[4] := 41;

Dat[5] := 14; Dat[6] := 21;

Dat[7] := 28; Dat[8] := 12;

Dat[9] := 15; Dat[10] := 35;

m := 0;

for k := 1 to 10 do

if Dat[k] < 25 then

begin

m := m+1

end;

writeln(m);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1312.

13
Задание 10 № 250

В таб­ли­це Dat пред­став­ле­ны дан­ные о ко­ли­че­стве голосов, по­дан­ных за 10 ис­пол­ни­те­лей на­род­ных песен (Dat[1] — ко­ли­че­ство голосов, по­дан­ных за пер­во­го исполнителя, Dat[2] — за вто­ро­го и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел к, m

Dat[1] := 16

Dat[2] := 20

Dat[3] := 20

Dat[4] := 41

Dat[5] := 14

Dat[6] := 21

Dat[7] := 28

Dat[8] := 11

Dat[9] := 15

Dat[10] := 35

m := 50

нц для к от 1 до 10

если Dat[к] < m то

m : = Dat[к]

все

КЦ

вывод m

КОН

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 16: Dat(2) = 20

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 21

Dat(7) = 28: Dat(8) = 11

Dat(9) = 15: Dat(10) = 35

m = 50

FOR k := 1 TO 10

IF Dat(k) < m THEN

m =Dat[k]

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1...10] of integer;

Begin

Dat[1] := 16; Dat[2] := 20;

Dat[3] := 20; Dat[4] := 41;

Dat[5] := 14; Dat[6] := 21;

Dat[7] := 28; Dat[8] := 11;

Dat[9] := 15; Dat[10] := 35;

m := 50;

for k := 1 to 10 do

if Dat[k] < m then

begin

m := Dat[k]

end;

writeln(m);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1313.

14
Задание 10 № 270

В таб­ли­це Dat пред­став­ле­ны дан­ные о ко­ли­че­стве голосов, по­дан­ных за 10 ис­пол­ни­те­лей на­род­ных песен (Dat[1] — ко­ли­че­ство голосов, по­дан­ных за пер­во­го исполнителя, Dat[2] — за вто­ро­го и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел к, m

Dat[1] := 16

Dat[2] := 20

Dat[3] := 20

Dat[4] := 41

Dat[5] := 14

Dat[6] := 21

Dat[7] := 28

Dat[8] := 12

Dat[9] := 15

Dat[10] := 35

m := 0

нц для к от 1 до 10

если Dat[к] > m то

m : = Dat[к]

все

КЦ

вывод m

КОН

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 16: Dat(2) = 20

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 21

Dat(7) = 28: Dat(8) = 12

Dat(9) = 15: Dat(10) = 35

m = 0

FOR k := 1 TO 10

IF Dat(k) > m THEN

m =Dat[k]

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1...10] of integer;

Begin

Dat[1] := 16; Dat[2] := 20;

Dat[3] := 20; Dat[4] := 41;

Dat[5] := 14; Dat[6] := 21;

Dat[7] := 28; Dat[8] := 12;

Dat[9] := 15; Dat[10] := 35;

m := 0;

for k := 1 to 10 do

if Dat[k] > m then

begin

m := Dat[k]

end;

writeln(m);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1314.

15
Задание 10 № 290

В таб­ли­це Dat хра­нят­ся дан­ные о ко­ли­че­стве сде­лан­ных за­да­ний уче­ни­ка­ми (Dat[1] за­да­ний сде­лал пер­вый ученик, Dat[2] — вто­рой и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел к, m, n

Dat[1] := 7

Dat[2] := 9

Dat[3] := 10

Dat[4] := 5

Dat[5] := 6

Dat[6] := 7

Dat[7] := 9

Dat[8] := 8

Dat[9] := 6

Dat[10] := 9

m := 10; n: = 0

нц для к от 1 до 10

если Dat[к] < m то

m : = Dat[к]

n: = к

все

КЦ

вывод n

КОН

DIM Dat(10) AS INTEGER

DIM k,m,n AS INTEGER

Dat[1] = 7

Dat[2] = 9

Dat[3] = 10

Dat[4] = 5

Dat[5] = 6

Dat[6] = 7

Dat[7] = 9

Dat[8] = 8

Dat[9] = 6

Dat[10] = 9

m = 10; n = 0

FOR k := 1 TO 10

IF Dat(k) < m THEN

m =Dat[k]

n = k

ENDIF

NEXT k

PRINT n

Var k, m, n: integer;

Dat: array[1...10] of integer;

Begin

Dat[1] := 7;

Dat[2] := 9;

Dat[3] := 10;

Dat[4] := 5;

Dat[5] := 6;

Dat[6] := 7;

Dat[7] := 9;

Dat[8] := 8;

Dat[9] := 6;

Dat[10] := 9;

m := 10; n: = 0;

for k := 1 to 10 do

if Dat[k] < m then

begin

m := Dat[k];

n := k

end;

writeln(n);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1315.

16
Задание 10 № 310

В таб­ли­це Dat хра­нят­ся дан­ные о ко­ли­че­стве уче­ни­ков в клас­сах (Dat[1] — ко­ли­че­ство уче­ни­ков в пер­вом классе, Dat[2] — во вто­ром и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:11]

цел к, m

Dat[1] := 20

Dat[2] := 27

Dat[3] := 19

Dat[4] := 28

Dat[5] := 26

Dat[6] := 22

Dat[7] := 24

Dat[8] := 28

Dat[9] := 26

Dat[10] := 21

Dat[11] := 27

m := 0

нц для к от 1 до 11

если Dat[к] < 25 то

m : = Dat[к]

все

КЦ

вывод m

КОН

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat[1] = 20

Dat[2] = 27

Dat[3] = 19

Dat[4] = 28

Dat[5] = 26

Dat[6] = 22

Dat[7] = 24

Dat[8] = 28

Dat[9] = 26

Dat[10] = 21

Dat[11] = 27

m = 0

FOR k := 1 TO 11

IF Dat(k) < 25 THEN

m =Dat[ k]

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..11] of integer;

Begin

Dat[1] := 20;

Dat[2] := 27;

Dat[3] := 19;

Dat[4] := 28;

Dat[5] := 26;

Dat[6] := 22;

Dat[7] := 24;

Dat[8] := 28;

Dat[9] := 26;

Dat[10] := 21;

Dat[11] := 27;

m := 0

for k := 1 to 11 do

if Dat[k] < 25 then

begin

m := Dat[k];

end;

writeln(m);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1316.

17
Задание 10 № 330

В таб­ли­це Dat хра­нят­ся дан­ные о ко­ли­че­стве уче­ни­ков в клас­сах (Dat[1] — ко­ли­че­ство уче­ни­ков в пер­вом классе, Dat[2] — во вто­ром и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:11]

цел к, m

Dat[1] := 20

Dat[2] := 25

Dat[3] := 19

Dat[4] := 25

Dat[5] := 26

Dat[6] := 22

Dat[7] := 24

Dat[8] := 28

Dat[9] := 26

Dat[10] := 21

Dat[11] := 27

m := 0

нц для к от 1 до 11

если Dat[к] > 22 то

m : = m+1

все

КЦ

вывод m

КОН

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat[1] = 20

Dat[2] = 25

Dat[3] = 19

Dat[4] = 25

Dat[5] = 26

Dat[6] = 22

Dat[7] = 24

Dat[8] = 28

Dat[9] = 26

Dat[10] = 21

Dat[11] = 27

m = 0

FOR k := 1 TO 11

IF Dat(k) > 22 THEN

m =m+1

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..11] of integer;

Begin

Dat[1] := 20;

Dat[2] := 25;

Dat[3] := 19;

Dat[4] := 25;

Dat[5] := 26;

Dat[6] := 22;

Dat[7] := 24;

Dat[8] := 28;

Dat[9] := 26;

Dat[10] := 21;

Dat[11] := 27;

m := 0;

for k := 1 to 11 do

if Dat[k] > 22 then

begin

m := m+1;

end;

writeln(m);

End.

Источник: Демонстрационная вер­сия ГИА—2013 по информатике.

18
Задание 10 № 351

В таб­ли­це Dat хра­нят­ся оцен­ки (по де­ся­ти­балль­ной шкале) сту­ден­та по про­грам­ми­ро­ва­нию за 8 про­шед­ших с на­ча­ла учёбы се­мест­ров (Dat[1] — оцен­ка за пер­вый семестр, Dat[2] — за вто­рой и т. д.). Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го алгоритма, за­пи­сан­но­го на трёх ал­го­рит­ми­че­ских языках.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел к, m, term

Dat[1] := 7

Dat[2] := 7

Dat[3] := 6

Dat[4] := 8

Dat[5] := 4

Dat[6] := 5

Dat[7] := 4

Dat[8] := 7

term:=1 m := Dat[1]

нц для к от 2 до 8

если Dat[к] < m то

m:= Dat[k]

term := k

все

КЦ

вывод term

КОН

DIM k,m, term AS INTEGER

Dat[1] = 7

Dat[2] = 7

Dat[3] = 6

Dat[4] = 8

Dat[5] = 4

Dat[6] = 5

Dat[7] = 4

Dat[8] = 7

term:=1 m := Dat(1)

FOR k := 2 TO 8

IF Dat(k) < m THEN

m =Dat(k)

term = k

ENDIF

NEXT k

PRINT term

END

Var k, m, term: integer;

Dat: array[1...10] of integer;

Begin

Dat[1] := 7;

Dat[2] := 7;

Dat[3] := 6;

Dat[4] := 8;

Dat[5] := 4;

Dat[6] := 5;

Dat[7] := 4;

Dat[8] := 7;

term:=1 m := Dat[1];

for k := 2 to 8 do

if Dat[k] < m then

begin

m:= Dat[k];

term := k;

end;

writeln(term);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные варианты. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 1.

19
Задание 10 № 371

В таб­ли­це Dat хра­нят­ся оцен­ки (по де­ся­ти­балль­ной шкале) сту­ден­та по про­грам­ми­ро­ва­нию за 8 про­шед­ших с на­ча­ла учёбы се­мест­ров (Dat[1] — оцен­ка за пер­вый семестр, Dat[2] — за вто­рой и т. д.). Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го алгоритма, за­пи­сан­но­го на трёх ал­го­рит­ми­че­ских языках.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:8]

цел к, m, term

Dat[1] := 7

Dat[2] := 7

Dat[3] := 6

Dat[4] := 8

Dat[5] := 4

Dat[6] := 5

Dat[7] := 8

Dat[8] := 7

term:=1; m := Dat[1]

нц для к от 2 до 8

если Dat[к] > m то

m:= Dat[k]

term := k

все

КЦ

вывод term

КОН

DIM Dat(8) AS INTEGER

Dat[1] = 7

Dat[2] = 7

Dat[3] = 6

Dat[4] = 8

Dat[5] = 4

Dat[6] = 5

Dat[7] = 8

Dat[8] = 7

term = 1: m = Dat(1)

FOR k = 2 TO 8

IF Dat(k) > m THEN

m = Dat(k)

term = k

END IF

NEXT k

PRINT term

END

Var k, m, term: integer;

Dat: array[1..8] of integer;

Begin

Dat[1] := 7;

Dat[2] := 7;

Dat[3] := 6;

Dat[4] := 8;

Dat[5] := 4;

Dat[6] := 5;

Dat[7] := 8;

Dat[8] := 7;

term:=1; m := Dat[1];

for k := 2 to 8 do

if Dat[k] > m then

begin

m:= Dat[k];

term := k;

end;

write(term);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 2.

20
Задание 10 № 391

В таб­ли­це Dat хра­нят­ся дан­ные о ко­ли­че­стве крат­ко­сроч­ных командировок, в ко­то­рые при­хо­ди­лось ез­дить со­труд­ни­ку за по­след­ний год (Dat[1] — ко­ли­че­ство ко­ман­ди­ро­вок в январе, Dat[2] — ко­ли­че­ство ко­ман­ди­ро­вок в фев­ра­ле и т. д.). Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го алгоритма, за­пи­сан­но­го на трёх ал­го­рит­ми­че­ских языках.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:12]

цел к, m, month

Dat[1] := 5

Dat[2] := 5

Dat[3] := 6

Dat[4] := 8

Dat[5] := 4

Dat[6] := 5

Dat[7] := 4

Dat[8] := 7

Dat[9] := 4

Dat[10] := 4

Dat[11] := 8

Dat[12] := 7

month:=1; m := Dat[1]

нц для к от 2 до 12

если Dat[к] <= m то

m:= Dat[k];

month := k

все

КЦ

вывод month

КОН

DIM Dat(12) AS INTEGER

Dat[1] = 5

Dat[2] = 5

Dat[3] = 6

Dat[4] = 8

Dat[5] = 4

Dat[6] = 5

Dat[7] = 4

Dat[8] = 7

Dat[9] := 4

Dat[10] := 4

Dat[11] := 8

Dat[12] := 7

month = 1: m = Dat(1)

FOR k = 2 TO 12

IF Dat(k) <= m THEN

m = Dat(k)

month = k

END IF

NEXT k

PRINT month

END

Var k, m, month: integer;

Dat: array[1..12] of integer;

Begin

Dat[1] := 5;

Dat[2] := 5;

Dat[3] := 6;

Dat[4] := 8;

Dat[5] := 4;

Dat[6] := 5;

Dat[7] := 4;

Dat[8] := 7;

Dat[9] := 4;

Dat[10] := 4;

Dat[11] := 8;

Dat[12] := 7;

month: = 1; m := Dat[1];

for k := 2 to 12 do

if Dat[k] <= m then

begin

m:= Dat[k];

month := k;

end;

write(month);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 3.

21
Задание 10 № 411

В таб­ли­це Dat хра­нят­ся дан­ные о ко­ли­че­стве крат­ко­сроч­ных командировок, в ко­то­рые при­хо­ди­лось ез­дить со­труд­ни­ку за по­след­ний год (Dat[1] — ко­ли­че­ство ко­ман­ди­ро­вок в январе, Dat[2] — ко­ли­че­ство ко­ман­ди­ро­вок в фев­ра­ле и т. д.). Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го алгоритма, за­пи­сан­но­го на трёх ал­го­рит­ми­че­ских языках.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:12]

цел к, m, term

Dat[1] := 2

Dat[2] := 5

Dat[3] := 6

Dat[4] := 8

Dat[5] := 8

Dat[6] := 5

Dat[7] := 3

Dat[8] := 7

Dat[9] := 4

Dat[10] := 4

Dat[11] := 8

Dat[12] := 7

month:=1; m := Dat[1]

нц для к от 2 до 12

если Dat[к] >= m то

m:= Dat[k]

month := k

все

КЦ

вывод month

КОН

DIM Dat(12) AS INTEGER

Dat[1] = 2

Dat[2] = 5

Dat[3] = 6

Dat[4] = 8

Dat[5] = 8

Dat[6] = 5

Dat[7] = 3

Dat[8] = 7

Dat[9] = 4

Dat[10] = 4

Dat[11] = 8

Dat[12] = 7

month = 1: m = Dat(1)

FOR k = 2 TO 12

IF Dat(k) >= m THEN

m = Dat(k)

month = k

END IF

NEXT k

PRINT month

END

Var k, m, month: integer;

Dat: array[1...12] of integer;

Begin

Dat[1] := 2;

Dat[2] := 5;

Dat[3] := 6;

Dat[4] := 8;

Dat[5] := 8;

Dat[6] := 5;

Dat[7] := 3;

Dat[8] := 7;

Dat[9] := 4;

Dat[10] := 4;

Dat[11] := 8;

Dat[12] := 7;

month:=1; m := Dat[1];

for k := 2 to 12 do

if Dat[k] >= m then

begin

m:= Dat[k];

month := k;

end;

write(month);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 4.

22
Задание 10 № 431

В таб­ли­це Dat хра­нят­ся дан­ные о ко­ли­че­стве дет­ских праздников, ко­то­рые про­во­ди­ло кафе за по­след­ний год (Dat[1] — ко­ли­че­ство дет­ских празд­ни­ков в январе, Dat[2] — ко­ли­че­ство празд­ни­ков в фев­ра­ле и т. д.). Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го алгоритма, за­пи­сан­но­го на трёх ал­го­рит­ми­че­ских языках.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:12]

цел к, m, month

Dat[1] := 2

Dat[2] := 8

Dat[3] := 6

Dat[4] := 3

Dat[5] := 8

Dat[6] := 2

Dat[7] := 3

Dat[8] := 7

Dat[9] := 4

Dat[10] := 4

Dat[11] := 8

Dat[12] := 7

month:=1; m := Dat[1]

нц для к от 2 до 6

если Dat[к] > m то

m:= Dat[k]

month := k

все

КЦ

вывод month

КОН

DIM Dat(12) AS INTEGER

Dat[1] = 2

Dat[2] = 8

Dat[3] = 6

Dat[4] = 3

Dat[5] = 8

Dat[6] = 2

Dat[7] = 3

Dat[8] = 7

Dat[9] = 4

Dat[10] = 4

Dat[11] = 8

Dat[12] = 7

month = 1: m = Dat(1)

FOR k = 2 TO 6

IF Dat(k) > m THEN

m = Dat(k)

month = k

END IF

NEXT k

PRINT month

END

Var k, m, month: integer;

Dat: array[1...12] of integer;

Begin

Dat[1] := 2

Dat[2] := 8

Dat[3] := 6

Dat[4] := 3

Dat[5] := 8

Dat[6] := 2

Dat[7] := 3

Dat[8] := 7

Dat[9] := 4

Dat[10] := 4

Dat[11] := 8

Dat[12] := 7

month:=1; m := Dat[1];

for k := 2 to 6 do

if Dat[k] > m then

begin

m:= Dat[k];

month := k;

end;

write(month);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 5.

23
Задание 10 № 451

В таб­ли­це Dat хра­нят­ся дан­ные о ко­ли­че­стве дет­ских праздников, ко­то­рые про­во­ди­ло кафе за по­след­ний год (Dat[1] — ко­ли­че­ство дет­ских празд­ни­ков в январе, Dat[2] — ко­ли­че­ство празд­ни­ков в фев­ра­ле и т. д.). Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го алгоритма, за­пи­сан­но­го на трёх ал­го­рит­ми­че­ских языках.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:12]

цел к, m, month

Dat[1] := 2

Dat[2] := 8

Dat[3] := 6

Dat[4] := 3

Dat[5] := 8

Dat[6] := 2

Dat[7] := 3

Dat[8] := 7

Dat[9] := 8

Dat[10] := 3

Dat[11] := 8

Dat[12] := 7

month:=1; m := Dat[1]

нц для к от 8 до 12

если Dat[к] > m то

m:= Dat[k]

month := k

все

КЦ

вывод month

КОН

DIM Dat(12) AS INTEGER

Dat[1] = 2

Dat[2] = 8

Dat[3] = 6

Dat[4] = 3

Dat[5] = 8

Dat[6] = 2

Dat[7] = 3

Dat[8] = 7

Dat[9] = 8

Dat[10] = 3

Dat[11] = 8

Dat[12] = 7

month = 1: m = Dat(1)

FOR k = 8 TO 12

IF Dat(k) > m THEN

m = Dat(k)

month = k

END IF

NEXT k

PRINT month

END

Var k, m, month: integer;

Dat: array[1...12] of integer;

Begin

Dat[1] := 2

Dat[2] := 8

Dat[3] := 6

Dat[4] := 3

Dat[5] := 8

Dat[6] := 2

Dat[7] := 3

Dat[8] := 7

Dat[9] := 8

Dat[10] := 3

Dat[11] := 8

Dat[12] := 7

month:=1; m := Dat[1];

for k := 8 to 12 do

if Dat[k] > m then

begin

m:= Dat[k];

month := k;

end;

write(month);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 6.

24
Задание 10 № 471

В таб­ли­це Dat хра­нят­ся дан­ные о ко­ли­че­стве поездов, от­прав­ля­ю­щих­ся с цен­траль­но­го вок­за­ла го­ро­да на юг в пер­вой де­ка­де июля (Dat[1] — ко­ли­че­ство по­ез­дов пер­во­го числа, Dat[2] — ко­ли­че­ство по­ез­дов вто­ро­го числа и т. д.). Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го алгоритма, за­пи­сан­но­го на трёх ал­го­рит­ми­че­ских языках.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел k, m, day

Dat[1] := 2

Dat[2] := 6

Dat[3] := 3

Dat[4] := 5

Dat[5] := 4

Dat[6] := 4

Dat[7] := 5

Dat[8] := 3

Dat[9] := 6

Dat[10] := 2

day:=1; m := Dat[1]

нц для k от 2 до 10

если Dat[к] > m то

m:= Dat[k]

day := k

все

КЦ

вывод day

КОН

DIM Dat(10) AS INTEGER

Dat[1] = 2

Dat[2] = 6

Dat[3] = 3

Dat[4] = 5

Dat[5] = 4

Dat[6] = 4

Dat[7] = 5

Dat[8] = 3

Dat[9] = 6

Dat[10] = 2

day = 1: m = Dat(1)

FOR k = 2 TO 10

IF Dat(k) > m THEN

m = Dat(k)

day = k

END IF

NEXT k

PRINT day

END

Var k, m, day: integer;

Dat: array[1..10] of integer;

Begin

Dat[1] := 2;

Dat[2] := 6;

Dat[3] := 3;

Dat[4] := 5;

Dat[5] := 4;

Dat[6] := 4;

Dat[7] := 5;

Dat[8] := 3;

Dat[9] := 6;

Dat[10] := 2;

day:=1; m := Dat[1];

for k := 2 to 10 do

if Dat[k] > m then

begin

m:= Dat[k];

day := k;

end;

write(day);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 7.

25
Задание 10 № 491

В таб­ли­це Dat хра­нят­ся дан­ные о ко­ли­че­стве поездов, от­прав­ля­ю­щих­ся с цен­траль­но­го вок­за­ла го­ро­да на юг в пер­вой де­ка­де июля (Dat[1] — ко­ли­че­ство по­ез­дов пер­во­го числа, Dat[2] — ко­ли­че­ство по­ез­дов вто­ро­го числа и т. д.). Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го алгоритма, за­пи­сан­но­го на трёх ал­го­рит­ми­че­ских языках.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел k, m, day

Dat[1] := 6

Dat[2] := 2

Dat[3] := 5

Dat[4] := 3

Dat[5] := 4

Dat[6] := 4

Dat[7] := 3

Dat[8] := 5

Dat[9] := 2

Dat[10] := 6

day:=1; m := Dat[1]

нц для k от 2 до 10

если Dat[к] < m то

m:= Dat[k]

day := k

все

КЦ

вывод day

КОН

DIM Dat(10) AS INTEGER

Dat[1] = 6

Dat[2] = 2

Dat[3] = 5

Dat[4] = 3

Dat[5] = 4

Dat[6] = 4

Dat[7] = 3

Dat[8] = 5

Dat[9] = 2

Dat[10] = 6

day = 1: m = Dat(1)

FOR k = 2 TO 10

IF Dat(k) < m THEN

m = Dat(k)

day = k

END IF

NEXT k

PRINT day

END

Var k, m, day: integer;

Dat: array[1...10] of integer;

Begin

Dat[1] := 6;

Dat[2] := 2;

Dat[3] := 5;

Dat[4] := 3;

Dat[5] := 4;

Dat[6] := 4;

Dat[7] := 3;

Dat[8] := 5;

Dat[9] := 2;

Dat[10] := 6;

day:=1; m := Dat[1];

for k := 2 to 10 do

if Dat[k] < m then

begin

m:= Dat[k];

day := k;

end;

write(day);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 8.

26
Задание 10 № 511

В таб­ли­це Dat хра­нят­ся дан­ные о ко­ли­че­стве самолётов, от­прав­ля­ю­щих­ся из аэро­пор­та го­ро­да на юг в пер­вой де­ка­де ав­гу­ста (Dat[1] — ко­ли­че­ство самолётов пер­во­го числа, Dat[2] — ко­ли­че­ство самолётов вто­ро­го числа и т. д.). Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го алгоритма, за­пи­сан­но­го на трёх ал­го­рит­ми­че­ских языках.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел k, m, day

Dat[1] := 2

Dat[2] := 2

Dat[3] := 3

Dat[4] := 3

Dat[5] := 4

Dat[6] := 4

Dat[7] := 5

Dat[8] := 5

Dat[9] := 6

Dat[10] := 6

day:=1; m := Dat[1]

нц для k от 2 до 10

если Dat[k] >= m то

m:= Dat[k]

day := k

все

КЦ

вывод day

КОН

DIM Dat(10) AS INTEGER

Dat[1] = 2

Dat[2] = 2

Dat[3] = 3

Dat[4] = 3

Dat[5] = 4

Dat[6] = 4

Dat[7] = 5

Dat[8] = 5

Dat[9] = 6

Dat[10] = 6

day = 1: m = Dat(1)

FOR k = 2 TO 10

IF Dat(k) >= m THEN

m = Dat(k)

day = k

END IF

NEXT k

PRINT day

END

Var k, m, day: integer;

Dat: array[1...10] of integer;

Begin

Dat[1] := 2;

Dat[2] := 2;

Dat[3] := 3;

Dat[4] := 3;

Dat[5] := 4;

Dat[6] := 4;

Dat[7] := 5;

Dat[8] := 5;

Dat[9] := 6;

Dat[10] := 6;

day:=1; m := Dat[1];

for k := 2 to 10 do

if Dat[k] >= m then

begin

m:= Dat[k];

day := k;

end;

write(day);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 9.

27
Задание 10 № 531

В таб­ли­це Dat хра­нят­ся дан­ные о ко­ли­че­стве самолётов, от­прав­ля­ю­щих­ся из аэро­пор­та го­ро­да на юг в пер­вой де­ка­де ав­гу­ста (Dat[1] — ко­ли­че­ство самолётов пер­во­го числа, Dat[2] — ко­ли­че­ство самолётов вто­ро­го числа и т. д.). Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го алгоритма, за­пи­сан­но­го на трёх ал­го­рит­ми­че­ских языках.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел k, m, day

Dat[1] := 2

Dat[2] := 2

Dat[3] := 3

Dat[4] := 3

Dat[5] := 2

Dat[6] := 2

Dat[7] := 5

Dat[8] := 5

Dat[9] := 6

Dat[10] := 6

day:=1; m := Dat[1]

нц для k от 2 до 10

если Dat[к] =< m то

m:= Dat[k]

day := k

все

КЦ

вывод day

КОН

DIM Dat(10) AS INTEGER

Dat[1] = 2

Dat[2] = 2

Dat[3] = 3

Dat[4] = 3

Dat[5] = 2

Dat[6] = 2

Dat[7] = 5

Dat[8] = 5

Dat[9] = 6

Dat[10] = 6

day = 1: m = Dat(1)

FOR k = 2 TO 10

IF Dat(k) =< m THEN

m = Dat(k)

day = k

END IF

NEXT k

PRINT day

END

Var k, m, day: integer;

Dat: array[1...10] of integer;

Begin

Dat[1] := 2;

Dat[2] := 2;

Dat[3] := 3;

Dat[4] := 3;

Dat[5] := 2;

Dat[6] := 2;

Dat[7] := 5;

Dat[8] := 5;

Dat[9] := 6;

Dat[10] := 6;

day:=1; m := Dat[1];

for k := 2 to 10 do

if Dat[k] <= m then

begin

m:= Dat[k];

day := k;

end;

write(day);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 10.

28
Задание 10 № 551

В таб­ли­це Work хра­нят­ся дан­ные о ко­ли­че­стве заказов, при­ня­тых фир­мой «Алоэ» с пер­во­го по 15 ноября. (Work[1] − число заказов, при­ня­тых 1 ноября, Work[2] − 2 но­яб­ря и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования:

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Work[1:15]

цел к, m

Work[1] := 5; Work[2] := 4

Work[3] := 5; Work[4] := 7

Work[5] := 6; Work[6] := 12

Work[7] := 7; Work[8] := 3

Work[9] := 9; Work[10] := 7

Work[11] := 0;Work[12] := 9

Work[13] := 1;Work[14] := 0

Work[15] := 8

m := 0

нц для к от 1 до 15

если Work[k] < 7 то

m : = m+1

все

КЦ

вывод m

КОН

DIM Work(15) AS INTEGER

DIM k,m AS INTEGER

Work(1)= 5: Work(2)= 4

Work(3)= 5: Work(4) = 7

Work(5)= 6: Work(6)= 12

Work(7)= 7: Work(8)= 3

Work(9)= 9: Work(10)= 7

Work(11)= 0: Work(12)= 9

Work(13)= 1: Work(14)= 0

Work(15)= 8

m = 0

FOR k = 1 TO 15

IF Work(k) < 7 THEN

m = m + 1

END IF

NEXT k

PRINT m

Var k, m: integer;

Work: array[1..15] of integer;

Begin

Work[1] := 5; Work[2] := 4;

Work[3] := 5; Work[4] := 7;

Work[5] := 6; Work[6] := 12;

Work[7] := 7; Work[8] := 3;

Work[9] := 9; Work[10] := 7;

Work[11] := 0; Work[12] := 9;

Work[13] := 1; Work[14] := 0;

Work[15] := 8;

m := 0;

For k := 1 to 15 Do

If Work[k] < 7 Then

Begin

m := m + 1;

End;

Writeln(m);

End.

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 07.05.2013 ва­ри­ант ИН9601.

29
Задание 10 № 571

В таб­ли­це Work хра­нят­ся дан­ные о ко­ли­че­стве заказов, при­ня­тых фир­мой «Конфетти» с пер­во­го по 15 декабря. (Work[1] − число заказов, при­ня­тых 1 декабря, Work[2] − 2 де­каб­ря и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования:

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Work[1:15]

цел к, m

Work[1] := 5; Work[2] := 4

Work[3] := 5; Work[4] := 7

Work[5] := 6; Work[6] := 12

Work[7] := 7; Work[8] := 3

Work[9] := 9; Work[10] := 7

Work[11] := 0;Work[12] := 9

Work[13] := 1;Work[14] := 0

Work[15] := 8

m := 0

нц для к от 1 до 15

если Work[k] > 6 то

m : = m+1

все

КЦ

вывод m

КОН

DIM Work(15) AS INTEGER

DIM k,m AS INTEGER

Work(1)= 5: Work(2)= 4

Work(3)= 5: Work(4) = 7

Work(5)= 6: Work(6)= 12

Work(7)= 7: Work(8)= 3

Work(9)= 9: Work(10)= 7

Work(11)= 0: Work(12)= 9

Work(13)= 1: Work(14)= 0

Work(15)= 8

m = 0

FOR k = 1 TO 15

IF Work(k) > 6 THEN

m = m + 1

END IF

NEXT k

PRINT m

Var k, m: integer;

Work: array[1..15] of integer;

Begin

Work[1] := 5; Work[2] := 4;

Work[3] := 5; Work[4] := 7;

Work[5] := 6; Work[6] := 12;

Work[7] := 7; Work[8] := 3;

Work[9] := 9; Work[10] := 7;

Work[11] := 0; Work[12] := 9;

Work[13] := 1; Work[14] := 0;

Work[15] := 8;

m := 0;

For k := 1 to 15 Do

If Work[k] > 6 Then

Begin

m := m + 1;

End;

Writeln(m);

End.

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 07.05.2013 ва­ри­ант ИН9602.

30
Задание 10 № 591

В таб­ли­це Tur хра­нят­ся дан­ные о ко­ли­че­стве ребят, хо­див­ших в поход вме­сте с ту­ри­сти­че­ским клу­бом «Полянка». (Tur[1] — число ребят в 2001 году, Tur[2] — в 2002 году и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования:

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Tur [1:11]

цел к, m

Tur[1]:= 1; Tur[2]:= 11;

Tur[3]:= 8; Tur[4]:= 12;

Tur[5]:= 5; Tur[6]:= 6;

Tur[7]:= 15; Tur[8]:= 16;

Tur[9]:= 16; Tur[10]:= 21;

Tur[11]:= 7;

m := 0

нц для к от 1 до 11

если Tur[k] < 10 то

m : = m+Tur[k]

все

КЦ

вывод m

КОН

DIM Tur(11) AS INTEGER

DIM k,m AS INTEGER

Tur(1)= 1: Tur(2)= 11

Tur(3)= 8: Tur(4) = 12

Tur(5)= 5: Tur(6)= 6

Tur(7)= 15: Tur(8)= 16

Tur(9)= 16: Tur(10)= 21

Tur(11)= 7

m = 0

FOR k = 1 TO 11

IF Tur(k) < 10 THEN

m : = m+Tur(k)

END IF

NEXT k

PRINT m

Var k, m: integer;

Tur: array[1..11] of integer;

Begin

Tur[1]:= 1; Tur[2]:= 11;

Tur[3]:= 8; Tur[4]:= 12;

Tur[5]:= 5; Tur[6]:= 6;

Tur[7]:= 15; Tur[8]:= 16;

Tur[9]:= 16; Tur[10]:= 21;

Tur[11]:= 7;

m := 0;

For k := 1 to 11 Do

If Tur[k] < 10 Then

Begin

m := m + Tur[k];

End;

Writeln(m);

End.

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 10.04.2013 ва­ри­ант ИН9501.

31
Задание 10 № 611

В таб­ли­це Tur хра­нят­ся дан­ные о ко­ли­че­стве ребят, хо­див­ших в поход вме­сте с ту­ри­сти­че­ским клу­бом «Полянка». (Tur[1] — число ребят в 2001 году, Tur[2] — в 2002 году и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования:

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Tur [1:11]

цел k, m

Tur[1]:= 1; Tur[2]:= 11;

Tur[3]:= 8; Tur[4]:= 12;

Tur[5]:= 5; Tur[6]:= 6;

Tur[7]:= 15; Tur[8]:= 16;

Tur[9]:= 16; Tur[10]:= 21;

Tur[11]:= 7;

m := 0

нц для к от 1 до 11

если Tur[k] > 12 то

m : = m+Tur[k]

все

КЦ

вывод m

КОН

DIM Tur(11) AS INTEGER

DIM k,m AS INTEGER

Tur(1)= 1: Tur(2)= 11

Tur(3)= 8: Tur(4) = 12

Tur(5)= 5: Tur(6)= 6

Tur(7)= 15: Tur(8)= 16

Tur(9)= 16: Tur(10)= 21

Tur(11)= 7

m = 0

FOR k = 1 TO 11

IF Tur(k) > 12 THEN

m : = m+Tur(k)

END IF

NEXT k

PRINT m

Var k, m: integer;

Tur: array[1..11] of integer;

Begin

Tur[1]:= 1; Tur[2]:= 11;

Tur[3]:= 8; Tur[4]:= 12;

Tur[5]:= 5; Tur[6]:= 6;

Tur[7]:= 15; Tur[8]:= 16;

Tur[9]:= 16; Tur[10]:= 21;

Tur[11]:= 7;

m := 0;

For k := 1 to 11 Do

If Tur[k] > 12 Then

Begin

m := m + Tur[k];

End;

Writeln(m);

End.

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 10.04.2013 ва­ри­ант ИН9502.

32
Задание 10 № 631

В таб­ли­це Ani хра­нят­ся дан­ные о чис­лен­но­сти обе­зьян в зоо­пар­ке го­ро­да Тулы (Ani[1] — число обе­зьян в 2001 году, Ani[2] — в 2002 и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования:

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Ani [1:12]

цел k, m

Ani[1]:= 17; Ani[2]:= 17;

Ani[3]:= 19; Ani[4]:= 21;

Ani[5]:= 23; Ani[6]:= 22;

Ani[7]:= 24; Ani[8]:= 16;

Ani[9]:= 19; Ani[10]:= 21;

Ani[11]:= 17; Ani[12]:= 17;

m := 0

нц для к от 1 до 12

если Ani[k] = 17 то

m : = m+Ani[k]

все

КЦ

вывод m

КОН

DIM Ani(11) AS INTEGER

DIM k,m AS INTEGER

Ani(1):= 17: Ani(2):= 17

Ani(3):= 19: Ani(4):= 21

Ani(5):= 23: Ani(6):= 22

Ani(7):= 24: Ani(8):= 16

Ani(9):= 19: Ani(10):= 21

Ani(11):= 17: Ani(12):= 17

m = 0

FOR k = 1 TO 12

IF Ani(k) = 17 THEN

m : = m+Ani(k)

END IF

NEXT k

PRINT m

Var k, m: integer;

Ani: array[1..12] of integer;

Begin

Ani[1]:= 17; Ani[2]:= 17;

Ani[3]:= 19; Ani[4]:= 21;

Ani[5]:= 23; Ani[6]:= 22;

Ani[7]:= 24; Ani[8]:= 16;

Ani[9]:= 19; Ani[10]:= 21;

Ani[11]:= 17; Ani[12]:= 17;

m := 0;

For k := 1 to 12 Do

If Ani[k] = 17 Then

Begin

m := m + Ani[k];

End;

Writeln(m);

End.

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 31.01.2013 ва­ри­ант 1.

33
Задание 10 № 651

В таб­ли­це Sea хра­нят­ся дан­ные о ко­ли­че­стве россиян, от­ды­хав­ших на Чёрном море (Sea[1] — число рос­си­ян в 2001 году, Sea[2] — в 2002 и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования:

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Sea [1:12]

цел k, s

Sea[1]:= 170; Sea[2]:= 170;

Sea[3]:= 190; Sea[4]:= 210;

Sea[5]:= 230; Sea[6]:= 220;

Sea[7]:= 240; Sea[8]:= 160;

Sea[9]:= 190; Sea[10]:= 210;

Sea[11]:= 170; Sea[12]:= 170;

s := 100

нц для к от 1 до 12

если Sea[k] > 220 то

s : = s+Sea[k]

все

КЦ

вывод s

КОН

DIS Sea(11) AS INTEGER

DIS k,s AS INTEGER

Sea(1):= 170: Sea(2):= 170

Sea(3):= 190: Sea(4):= 210

Sea(5):= 230: Sea(6):= 220

Sea(7):= 240: Sea(8):= 160

Sea(9):= 190: Sea(10):= 210

Sea(11):= 170: Sea(12):= 170

s = 100

FOR k = 1 TO 12

IF Sea(k) > 220 THEN

s : = s+Sea(k)

END IF

NEXT k

PRINT s

Var k, s: integer;

Sea: array[1..12] of integer;

Begin

Sea[1]:= 170; Sea[2]:= 170;

Sea[3]:= 190; Sea[4]:= 210;

Sea[5]:= 230; Sea[6]:= 220;

Sea[7]:= 240; Sea[8]:= 160;

Sea[9]:= 190; Sea[10]:= 210;

Sea[11]:= 170; Sea[12]:= 170;

s := 100;

For k := 1 to 12 Do

If Sea[k] > 220 Then

Begin

s := s + Sea[k];

End;

Writeln(s);

End.

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 31.01.2013 ва­ри­ант 2.

34
Задание 10 № 671

В таб­ли­це Ves хра­нят­ся дан­ные о весе в ки­ло­грам­мах по груп­пе уча­щих­ся спор­тив­ной школы (Ves[1] — вес пер­во­го учащегося, Ves[2] — вес вто­ро­го уча­ще­го­ся и т. д.). Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го алгоритма, за­пи­сан­но­го на трёх ал­го­рит­ми­че­ских языках:

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Ves [1:14]

цел i, n

Ves[1]:= 25; Ves[2]:= 21;

Ves[3]:= 23; Ves[4]:= 28;

Ves[5]:= 30; Ves[6]:= 25;

Ves[7]:= 31; Ves[8]:= 28;

Ves[9]:= 25; Ves[10]:= 28;

Ves[11]:= 30; Ves[12]:= 27;

Ves[13]:= 26; Ves[14]:= 24;

n := Ves[1]

нц для i от 1 до 14

если Ves[i] < n то

n : = Ves[i]

все

КЦ

вывод n

КОН

DIS Ves(14) AS INTEGER

DIS i,n AS INTEGER

Ves(1)= 25: Ves(2)= 21

Ves(3)= 23: Ves(4)= 28

Ves(5)= 30: Ves(6)= 25

Ves(7)= 31: Ves(8)= 28

Ves(9)= 25: Ves(10)= 28

Ves(11)= 30: Ves(12)= 27

Ves(13)= 26: Ves(14)= 24

n = Ves(1)

FOR i = 1 TO 14

IF Ves(i) < n THEN

n : = Ves(i)

END IF

NEXT i

PRINT n

Var i, n: integer;

Ves: array[1..14] of integer;

Begin

Ves[1]:= 25; Ves[2]:= 21;

Ves[3]:= 23; Ves[4]:= 28;

Ves[5]:= 30; Ves[6]:= 25;

Ves[7]:= 31; Ves[8]:= 28;

Ves[9]:= 25; Ves[10]:= 28;

Ves[11]:= 30; Ves[12]:= 27;

Ves[13]:= 26; Ves[14]:= 24;

n := Ves[1];

For i := 1 to 14 Do

If Ves[i] < n Then

Begin

n : = Ves[i];

End;

Writeln(n);

End.

Источник: МИОО: Ди­а­гно­сти­че­ская работа по ин­фор­ма­ти­ке 15.03.2013 ва­ри­ант ИНФ9403.

35
Задание 10 № 691

В таб­ли­це Ves хра­нят­ся дан­ные о весе в ки­ло­грам­мах по груп­пе уча­щих­ся спор­тив­ной школы (Ves[1] — вес пер­во­го учащегося, Ves[2] — вес вто­ро­го уча­ще­го­ся и т. д.). Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го алгоритма, за­пи­сан­но­го на трёх ал­го­рит­ми­че­ских языках:

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Ves [1:14]

цел i, n

Ves[1]:= 25; Ves[2]:= 21;

Ves[3]:= 23; Ves[4]:= 28;

Ves[5]:= 30; Ves[6]:= 25;

Ves[7]:= 31; Ves[8]:= 28;

Ves[9]:= 25; Ves[10]:= 28;

Ves[11]:= 30; Ves[12]:= 27;

Ves[13]:= 26; Ves[14]:= 24;

n := 0

нц для i от 1 до 14

если Ves[i] > 26 то

n : = n + 1

все

КЦ

вывод n

КОН

DIS Ves(14) AS INTEGER

DIS i,n AS INTEGER

Ves(1)= 25: Ves(2)= 21

Ves(3)= 23: Ves(4)= 28

Ves(5)= 30: Ves(6)= 25

Ves(7)= 31: Ves(8)= 28

Ves(9)= 25: Ves(10)= 28

Ves(11)= 30: Ves(12)= 27

Ves(13)= 26: Ves(14)= 24

n = 0

FOR i = 1 TO 14

IF Ves(i) > 26 THEN

n : = n + 1

END IF

NEXT i

PRINT n

Var i, n: integer;

Ves: array[1..14] of integer;

Begin

Ves[1]:= 25; Ves[2]:= 21;

Ves[3]:= 23; Ves[4]:= 28;

Ves[5]:= 30; Ves[6]:= 25;

Ves[7]:= 31; Ves[8]:= 28;

Ves[9]:= 25; Ves[10]:= 28;

Ves[11]:= 30; Ves[12]:= 27;

Ves[13]:= 26; Ves[14]:= 24;

n := 0;

For i := 1 to 14 Do

If Ves[i] > 26 Then

Begin

n : = n + 1;

End;

Writeln(n);

End.

Источник: МИОО: Ди­а­гно­сти­че­ская работа по ин­фор­ма­ти­ке 15.03.2013 ва­ри­ант ИНФ9404.

36
Задание 10 № 711

В таб­ли­це Dat хра­нят­ся дан­ные о ко­ли­че­стве уче­ни­ков в клас­сах (Dat[1] — ко­ли­че­ство уче­ни­ков в пер­вом классе, Dat[2] — во вто­ром и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

целтаб Dat[1:10]

цел k, m

Dat[1] := 16

Dat[2] := 20

Dat[3] := 20

Dat[4] := 41

Dat[5] := 14

Dat[6] := 21

Dat[7] := 28

Dat[8] := 12

Dat[9] := 15

Dat[10] := 35

m := 0

нц для k от 1 до 10

если Dat[k]>m то

m := Dat[k]

все

кц

вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 16: Dat(2) = 20

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 21

Dat(7) = 28: Dat(8) = 12

Dat(9) = 15:Dat(10) = 35

m = 0

FOR k = 1 TO 10

IF Dat(k)>m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

Dat[1] := 16; Dat[2] := 20;

Dat[3] := 20; Dat[4] := 41;

Dat[5] := 14; Dat[6] := 21;

Dat[7] := 28; Dat[8] := 12;

Dat[9] := 15; Dat[10] := 35;

m := 0;

for k := 1 to 10 do

if Dat[k]>m then

begin

m := Dat[k]

end;

writeln(m);

End.

Источник: Демонстрационная вер­сия ГИА—2014 по информатике.

37
Задание 10 № 754

Школьник делал ла­бо­ра­тор­ную ра­бо­ту по физике, в ходе ко­то­рой из­ме­рил 10 раз силу тока и за­пи­сал по­ка­за­ния ам­пер­мет­ра в таб­ли­цу Tok (Tok[1] — ре­зуль­тат пер­во­го измерения, Tok[2] — вто­ро­го и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел­таб Tok[1:10]

цел k, m

Tok[1] := 10; Tok[2] := 14

Tok[3] := 15; Tok[4] := 4

Tok[5] := 12; Tok[6] := 6

Tok[7] := 3; Tok[8] := 5

Tok[9] := 5; Tok[10] := 10

m := 22

нц для k от 1 до 10

если Tok[k] > 10 то

m := m - 1

все

кц

вывод m

кон

DIM Tok(10) AS INTEGER

DIM k,m AS INTEGER

Tok(1)= 10: Tok(2)= 14

Tok(3)= 15: Tok(4) = 4

Tok(5)= 12: Tok(6)= 6

Tok(7)= 3: Tok(8)= 5

Tok(9)= 5: Tok(10)= 10

m = 22

FOR k = 1 TO 10

IF Tok(k) > 10 THEN

m = m - 1

END IF

NEXT k

PRINT m

Var k, m: integer;

Tok: array[1..10] of integer;

Begin

Tok[1] := 10; Tok[2] := 14;

Tok[3] := 15; Tok[4] := 4;

Tok[5] := 12; Tok[6] := 6;

Tok[7] := 3; Tok[8] := 5;

Tok[9] := 5; Tok[10] := 10;

m := 22;

For k := 1 to 10 Do

If Tok[k] > 10 Then

Begin

m := m - 1;

End;

Writeln(m);

End.

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 18.10.2013 ва­ри­ант ИНФ9101.

38
Задание 10 № 774

Школьник делал ла­бо­ра­тор­ную ра­бо­ту по физике, в ходе ко­то­рой из­ме­рил 10 раз силу тока и за­пи­сал по­ка­за­ния ам­пер­мет­ра в таб­ли­цу Tok (Tok[1] — ре­зуль­тат пер­во­го измерения, Tok[2] — вто­ро­го и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел­таб Tok[1:10]

цел k, m

Tok[1] := 10; Tok[2] := 14

Tok[3] := 15; Tok[4] := 4

Tok[5] := 12; Tok[6] := 6

Tok[7] := 3; Tok[8] := 5

Tok[9] := 5; Tok[10] := 10

m := 0

нц для k от 1 до 10

если Tok[k] > 6 то

m := m + 2

все

кц

вывод m

кон

DIM Tok(10) AS INTEGER

DIM k,m AS INTEGER

Tok(1)= 10: Tok(2)= 14

Tok(3)= 15: Tok(4) = 4

Tok(5)= 12: Tok(6)= 6

Tok(7)= 3: Tok(8)= 5

Tok(9)= 5: Tok(10)= 10

m = 0

FOR k = 1 TO 10

IF Tok(k) > 6 THEN

m = m + 2

END IF

NEXT k

PRINT m

Var k, m: integer;

Tok: array[1..10] of integer;

Begin

Tok[1] := 10; Tok[2] := 14;

Tok[3] := 15; Tok[4] := 4;

Tok[5] := 12; Tok[6] := 6;

Tok[7] := 3; Tok[8] := 5;

Tok[9] := 5; Tok[10] := 10;

m := 0;

For k := 1 to 10 Do

If Tok[k] > 6 Then

Begin

m := m + 2;

End;

Writeln(m);

End.

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 18.10.2013 ва­ри­ант ИНФ9102.

39
Задание 10 № 806

Владелец круп­но­го яб­ло­не­во­го сада в те­че­ние 12 лет за­пи­сы­вал в таб­ли­цу App ко­ли­че­ство со­бран­но­го урожая. (App[1] — ко­ли­че­ство тонн яблок, со­бран­ных за пер­вый год, App[2] — за вто­рой и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

алг

нач

цел­таб App[1:12]

цел k, m

App[1] := 100; App[2] := 128

App[3] := 80; App[4] := 99

App[5] := 120; App[6] := 69

App[7] := 55; App[8] := 115

App[9] := 84; App[10] := 111

App[11] := 59; App[12] := 100

m := 0

нц для k от 1 до 12

если App[k] > 100 то

m := m + 1

все

кц

m := m + 10

вывод m

кон

DIM App(12) AS INTEGER

DIM k,m AS INTEGER

App(1)= 100: App(2)= 128

App(3)= 80: App(4) = 99

App(5)= 120: App(6)= 69

App(7)= 55: App(8)= 115

App(9)= 84: App(10)= 111

App(11)= 59: App(12)= 100

m = 0

FOR k = 1 TO 12

IF App(k) > 100 THEN

m = m + 1

END IF

NEXT k

m = m + 10

PRINT m

Var k, m: integer;

App: array[1..12] of integer;

Begin

App[1] := 100; App[2] := 128;

App[3] := 80; App[4] := 99;

App[5] := 120; App[6] := 69;

App[7] := 55; App[8] := 115;

App[9] := 84; App[10] := 111;

App[11] := 59; App[12] := 100;

m := 0;

For k := 1 to 12 Do

If App[k] > 100 Then

Begin

m := m + 1;

End;

m : = m + 10;

Writeln(m);

End.

Источник: МИОО: Ди­а­гно­сти­че­ская работа по ин­фор­ма­ти­ке 06.03.2014 ва­ри­ант ИН90701.

40
Задание 10 № 826

Владелец круп­но­го яб­ло­не­во­го сада в те­че­ние 12 лет за­пи­сы­вал в таб­ли­цу App ко­ли­че­ство со­бран­но­го урожая. (App[1] — ко­ли­че­ство тонн яблок, со­бран­ных за пер­вый год, App[2] — за вто­рой и т. д.). Определите, какое

число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

алг

нач

цел­таб App[1:12]

цел k, m

App[1] := 100; App[2] := 128

App[3] := 80; App[4] := 99

App[5] := 120; App[6] := 69

App[7] := 55; App[8] := 115

App[9] := 84; App[10] := 111

App[11] := 59; App[12] := 100

m := 0

нц для k от 1 до 12

если App[k] < 80 то

m := m + 1

все

кц

m := m + 20

вывод m

кон

DIM App(12) AS INTEGER

DIM k,m AS INTEGER

App(1) = 100: App(2)= 128

App(3) = 80: App(4) = 99

App(5) = 120: App(6)= 69

App(7) = 55: App(8)= 115

App(9) = 84: App(10)= 111

App(11)= 59: App(12)= 100

m = 0

FOR k = 1 TO 12

IF App(k) < 80 THEN

m = m + 1

END IF

NEXT k

m = m + 20

PRINT m

Var k, m: integer;

App: array[1..12] of integer;

Begin

App[1] := 100; App[2] := 128;

App[3] := 80; App[4] := 99;

App[5] := 120; App[6] := 69;

App[7] := 55; App[8] := 115;

App[9] := 84; App[10] := 111;

App[11] := 59; App[12] := 100;

m := 0;

For k := 1 to 12 Do

If App[k] < 80 Then

Begin

m := m + 1;

End;

m : = m + 20;

Writeln(m);

End.

Источник: МИОО: Ди­а­гно­сти­че­ская работа по ин­фор­ма­ти­ке 06.03.2014 ва­ри­ант ИН90702.
Пояснение · ·

41
Задание 10 № 848

В таб­ли­це Dat хра­нят­ся от­мет­ки уча­щих­ся 9 клас­са за са­мо­сто­я­тель­ную ра­бо­ту (Dat[1] — отметка пер­во­го учащегося, Dat[2] — вто­ро­го и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел­таб Dat[1:10]

цел k, m

Dat[1] := 4

Dat[2] := 5

Dat[3] := 4

Dat[4] := 3

Dat[5] := 2

Dat[6] := 3

Dat[7] := 4

Dat[8] := 5

Dat[9] := 5

Dat[10] := 3

m := 0

нц для k от 1 до 10

если Dat[k] > 3 то

m := m + 1

все

кц

вывод m

кон

DIM Dat(10) AS INTEGER

DIM k, m AS INTEGER

Dat(1) = 4: Dat(2) = 5

Dat(3) = 4: Dat(4) = 3

Dat(5) = 2: Dat(6) = 3

Dat(7) = 4: Dat(8) = 5

Dat(9) = 5: Dat(10) = 3

m = 0

FOR k = 1 TO 10

IF Dat(k) > 3 THEN

m = m + 1

END IF

NEXT k

PRINT m

END

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

Dat[1] := 4; Dat[2] := 5;

Dat[3] := 4; Dat[4] := 3;

Dat[5] := 2; Dat[6] := 3;

Dat[7] := 4; Dat[8] := 5;

Dat[9] := 5; Dat[10] := 3;

m := 0;

for k := 1 to 10 do

if Dat[k] > 3 then

begin

m := m + 1;

end;

writeln(m);

End.

Источник: МИОО: Ди­а­гно­сти­че­ская ра­бо­та по ин­фор­ма­ти­ке 19.12.2013 ва­ри­ант ИНФ90301.

42
Задание 10 № 868

В таб­ли­це Dat хра­нят­ся от­мет­ки уча­щих­ся 9 клас­са за са­мо­сто­я­тель­ную ра­бо­ту (Dat[1] – от­мет­ка пер­во­го учащегося, Dat[2] – вто­ро­го и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел­таб Dat[1:10]

цел k, m

Dat[1] := 4

Dat[2] := 5

Dat[3] := 4

Dat[4] := 3

Dat[5] := 2

Dat[6] := 3

Dat[7] := 4

Dat[8] := 5

Dat[9] := 5

Dat[10] := 3

m := 0

нц для k от 1 до 10

если Dat[k] < 4 то

m := m + Dat[k]

все

кц

вывод m

кон

DIM Dat(10) AS INTEGER

DIM k, m AS INTEGER

Dat(1) = 4: Dat(2) = 5

Dat(3) = 4: Dat(4) = 3

Dat(5) = 2: Dat(6) = 3

Dat(7) = 4: Dat(8) = 5

Dat(9) = 5: Dat(10) = 3

m = 0

FOR k = 1 TO 10

IF Dat(k) < 4 THEN

m = m + Dat(k)

END IF

NEXT k

PRINT m

END

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

Dat[1] := 4; Dat[2] := 5;

Dat[3] := 4; Dat[4] := 3;

Dat[5] := 2; Dat[6] := 3;

Dat[7] := 4; Dat[8] := 5;

Dat[9] := 5; Dat[10] := 3;

m := 0;

for k := 1 to 10 do

if Dat[k] < 4 then

begin

m := m + Dat[k];

end;

writeln(m);

End.

Источник: МИОО: Ди­а­гно­сти­че­ская ра­бо­та по ин­фор­ма­ти­ке 19.12.2013 ва­ри­ант ИНФ90302.

43
Задание 10 № 889

Сотрудник ме­те­о­бю­ро в ходе из­ме­ре­ний сред­не­су­точ­ной тем­пе­ра­ту­ры за­пи­сы­вал по­ка­за­ния тер­мо­мет­ра в таб­ли­цу Tem (Tem[1] — температура, по­лу­чен­ная в ре­зуль­та­те пер­во­го измерения, Tem[2] — вто­ро­го и т. д.).

Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел­таб Tem[1:12]

цел k, b

b := 15

Tem[1] := 22; Tem[2] := 25

Tem[3] := 20; Tem[4] := 18

Tem[5] := 16; Tem[6] := 14

Tem[7] := 20; Tem[8] := 23

Tem[9] := 17; Tem[10] := 19

Tem[11] := 20; Tem[12] := 21

нц для k от 1 до 12

если Tem[k] < 20 то

b := b + 1

все

кц

вывод b

кон

DIM Tem(12) AS INTEGER

DIM k,b AS INTEGER

b = 15

Tem(1)= 22: Tem(2)= 25

Tem(3)= 20: Tem(4) = 18

Tem(5)= 16: Tem(6)= 14

Tem(7)= 20: Tem(8)= 23

Tem(9)= 17: Tem(10)= 19

Tem(11)= 20: Tem(12)= 21

FOR k = 1 TO 12

IF Tem(k) < 20 THEN

b = b + 1

END IF

NEXT k

PRINT b

Var k, b: integer;

Tem: array[1..12] of integer;

Begin

b := 15;

Tem[1] := 22; Tem[2] := 25;

Tem[3] := 20; Tem[4] := 18;

Tem[5] := 16; Tem[6] := 14;

Tem[7] := 20; Tem[8] := 23;

Tem[9] := 17; Tem[10] := 19;

Tem[11] := 20; Tem[12] := 21;

For k := 1 to 12 Do

If Tem[k] < 20 Then

b := b + 1;

Writeln(b);

End.

Источник: МИОО: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 17.02.2014 ва­ри­ант ИН90501.

44
Задание 10 № 909

Сотрудник ме­те­о­бю­ро в ходе из­ме­ре­ний сред­не­су­точ­ной тем­пе­ра­ту­ры за­пи­сы­вал по­ка­за­ния тер­мо­мет­ра в таб­ли­цу Tem (Tem[1] — температура, по­лу­чен­ная в ре­зуль­та­те пер­во­го измерения, Tem[2] — вто­ро­го и т. д.).

Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел­таб Tem[1:12]

цел k, b

b := 0

Tem[1] := 22; Tem[2] := 25

Tem[3] := 20; Tem[4] := 18

Tem[5] := 16; Tem[6] := 14

Tem[7] := 20; Tem[8] := 23

Tem[9] := 17; Tem[10] := 19

Tem[11] := 20; Tem[12] := 21

нц для k от 1 до 12

если Tem[k] < 19 то

b := b + Tem[k]

все

кц

вывод b

кон

DIM Tem(12) AS INTEGER

DIM k,b AS INTEGER

b = 0

Tem(1)= 22: Tem(2)= 25

Tem(3)= 20: Tem(4) = 18

Tem(5)= 16: Tem(6)= 14

Tem(7)= 20: Tem(8)= 23

Tem(9)= 17: Tem(10)= 19

Tem(11)= 20: Tem(12)= 21

FOR k = 1 TO 12

IF Tem(k) < 19 THEN

b = b + Tem[k]

END IF

NEXT k

PRINT b

Var k, b: integer;

Tem: array[1..12] of integer;

Begin

b := 0;

Tem[1] := 22; Tem[2] := 25;

Tem[3] := 20; Tem[4] := 18;

Tem[5] := 16; Tem[6] := 14;

Tem[7] := 20; Tem[8] := 23;

Tem[9] := 17; Tem[10] := 19;

Tem[11] := 20; Tem[12] := 21;

For k := 1 to 12 Do

If Tem[k] < 19 Then

b := b + Tem[k];

Writeln(b);

End.

Источник: МИОО: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 17.02.2014 ва­ри­ант ИН90502.

45
Задание 10 № 929

Садовник, ра­бо­тая в оран­же­рее бо­та­ни­че­ско­го сада, за­пи­сы­вал в таб­ли­цу Flow ко­ли­че­ство видов растений, цве­ту­щих в те­ку­щем месяце. (Flow[1] — ко­ли­че­ство цве­ту­щих рас­те­ний в январе, Flow[2] – в фев­ра­ле и т. д.).

Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел­таб Flow[1:12]

цел k, m

Flow[1] := 25; Flow[2] := 33

Flow[3] := 45; Flow[4] := 56

Flow[5] := 78; Flow[6] := 112

Flow[7] := 120;Flow[8] := 133

Flow[9] := 97; Flow[10] := 77

Flow[11] := 59;Flow[12] := 34

m := 23

нц для k от 1 до 12

если Flow[k] < 50 то

m := m + 1

все

кц

вывод m

кон

DIM Flow(12) AS INTEGER

DIM k,m AS INTEGER

Flow(1)= 25: Flow(2)= 33

Flow(3)= 45: Flow(4) = 56

Flow(5)= 78: Flow(6)= 112

Flow(7)= 120: Flow(8)= 133

Flow(9)= 97: Flow(10)= 77

Flow(11)= 59: Flow(12)= 34

m = 23

FOR k = 1 TO 12

IF Flow(k) < 50 THEN

m = m + 1

END IF

NEXT k

PRINT m

Var k, m: integer;

Flow: array[1..12] of integer;

Begin

Flow[1] := 25; Flow[2] := 33;

Flow[3] := 45; Flow[4] := 56;

Flow[5] := 78; Flow[6] := 112;

Flow[7] := 120; Flow[8] := 133;

Flow[9] := 97; Flow[10] := 77;

Flow[11] := 59; Flow[12] := 34;

m := 23;

For k := 1 to 12 Do

If Flow[k] < 50 Then

Begin

m := m + 1;

End;

Writeln(m);

End.

Источник: МИОО: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 24.04.2014 ва­ри­ант ИН90801.

46
Задание 10 № 949

Садовник, ра­бо­тая в оран­же­рее бо­та­ни­че­ско­го сада, за­пи­сы­вал в таб­ли­цу Flow ко­ли­че­ство видов растений, цве­ту­щих в те­ку­щем месяце. (Flow[1] — ко­ли­че­ство цве­ту­щих рас­те­ний в январе, Flow[2] – в фев­ра­ле и т. д.).

Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел­таб Flow[1:12]

цел k, m

Flow[1] := 25; Flow[2] := 33

Flow[3] := 45; Flow[4] := 56

Flow[5] := 78; Flow[6] := 112

Flow[7] := 120;Flow[8] := 133

Flow[9] := 97; Flow[10] := 77

Flow[11] := 59;Flow[12] := 34

m := 35

нц для k от 1 до 12

если Flow[k] > 100 то

m := m + 1

все

кц

вывод m

кон

DIM Flow(12) AS INTEGER

DIM k,m AS INTEGER

Flow(1)= 25: Flow(2)= 33

Flow(3)= 45: Flow(4) = 56

Flow(5)= 78: Flow(6)= 112

Flow(7)= 120: Flow(8)= 133

Flow(9)= 97: Flow(10)= 77

Flow(11)= 59: Flow(12)= 34

m = 35

FOR k = 1 TO 12

IF Flow(k) > 100 THEN

m = m + 1

END IF

NEXT k

PRINT m

Var k, m: integer;

Flow: array[1..12] of integer;

Begin

Flow[1] := 25; Flow[2] := 33;

Flow[3] := 45; Flow[4] := 56;

Flow[5] := 78; Flow[6] := 112;

Flow[7] := 120; Flow[8] := 133;

Flow[9] := 97; Flow[10] := 77;

Flow[11] := 59; Flow[12] := 34;

m := 35;

For k := 1 to 12 Do

If Flow[k] > 100 Then

Begin

m := m + 1;

End;

Writeln(m);

End.

Источник: МИОО: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 24.04.2014 ва­ри­ант ИН90802.

47
Задание 10 № 1021

Известная авиа­ком­па­ния за­но­си­ла дан­ные о ко­ли­че­стве уте­рян­но­го ба­га­жа за год в таб­ли­цу Lose. Всего были за­не­се­ны дан­ные за по­след­ние 10 лет ра­бо­ты ком­па­нии (Lose[1] — ко­ли­че­ство уте­рян­но­го ба­га­жа за пер­вый год работы, Lose[2] — за вто­рой год и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел­таб Lose[1:10]

цел t, m

Lose[1] := 1; Lose[2] := 5

Lose[3] := 3; Lose[4] := 6

Lose[5] := 7; Lose[6] := 12

Lose[7] := 1; Lose[8] := 3

Lose[9] := 3; Lose[10] := 1

m := 0

нц для t от 1 до 10

если Lose[t] > 3 то

m := m + Lose[t]

все

кц

вывод m

кон

DIM Lose(10) AS INTEGER

DIM t,m AS INTEGER

Lose(1) = 1: Lose(2) = 5

Lose(3) = 3: Lose(4) = 6

Lose(5) = 7: Lose(6) = 12

Lose(7) = 1: Lose(8) = 3

Lose(9) = 3: Lose(10) = 1

m = 0

FOR t = 1 TO 10

IF Lose(t) > 3 THEN

m = m + Lose(t)

END IF

NEXT k

PRINT m

Var t, m: integer;

Lose: array[1..10] of integer;

Begin

Lose[1] := 1; Lose[2] := 5;

Lose[3] := 3; Lose[4] := 6;

Lose[5] := 7; Lose[6] := 12;

Lose[7] := 1; Lose[8] := 3;

Lose[9] := 3; Lose[10] := 1;

m := 0;

For t := 1 to 10 Do

If Lose[t] > 3 Then

Begin

m := m + Lose[t];

End;

Writeln(m);

End.

Источник: СтатГрад: Тренировочная ра­бо­та по ин­фор­ма­ти­ке 20.11.14 ва­ри­ант ИН90101.

48
Задание 10 № 1041

Известная авиа­ком­па­ния за­но­си­ла дан­ные о ко­ли­че­стве уте­рян­но­го ба­га­жа за год в таб­ли­цу Lose. Всего были за­не­се­ны дан­ные за по­след­ние 10 лет ра­бо­ты ком­па­нии (Lose[1] — ко­ли­че­ство уте­рян­но­го ба­га­жа за пер­вый год работы, Lose[2] — за вто­рой год и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел­таб Lose[1:10]

цел t, m

Lose[1] := 1; Lose[2] := 5

Lose[3] := 3; Lose[4] := 6

Lose[5] := 7; Lose[6] := 12

Lose[7] := 1; Lose[8] := 3

Lose[9] := 3; Lose[10] := 1

m := 0

нц для t от 1 до 10

если Lose[t] < 6 то

m := m + Lose[t]

все

кц

вывод m

кон

DIM Lose(10) AS INTEGER

DIM t,m AS INTEGER

Lose(1)= 1: Lose(2)= 5

Lose(3)= 3: Lose(4) = 6

Lose(5)= 7: Lose(6)= 12

Lose(7)= 1: Lose(8)= 3

Lose(9)= 3: Lose(10)= 1

m = 0

FOR t = 1 TO 10

IF Lose(t) < 6 THEN

m = m + Lose(t)

END IF

NEXT k

PRINT m

Var t, m: integer;

Lose: array[1..10] of integer;

Begin

Lose[1] := 1; Lose[2] := 5;

Lose[3] := 3; Lose[4] := 6;

Lose[5] := 7; Lose[6] := 12;

Lose[7] := 1; Lose[8] := 3;

Lose[9] := 3; Lose[10] := 1;

m := 0;

For t := 1 to 10 Do

If Lose[t] < 6 Then

Begin

m := m + Lose[t];

End;

Writeln(m);

End.

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 20.11.14 ва­ри­ант ИН90102.

49
Задание 10 № 1061

В таб­ли­це A хра­нят­ся дан­ные о ко­ли­че­стве призёров олим­пи­а­ды по про­грам­ми­ро­ва­нию по де­вя­ти окру­гам Москвы. Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го алгоритма, за­пи­сан­но­го на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел­таб A[1:9]

цел k, score

A[1]:=6; A[2]:=11

A[3]:=7; A[4]:=12

A[5]:=13; A[6]:=5

A[7]:=9; A[8]:=3

A[9]:=4

score:= 0

нц для k от 1 до 9

если A[k] >= 9 то

score:=score+A[k]

все

кц

вывод score

кон

DIM A(9) AS INTEGER

DIM k, score AS INTEGER

A(1)=6: A(2)=11

A(3)=7: A(4)=12

A(5)=13: A(6)=5

A(7):=9: A(8):=3

A(9):=4

score=0

FOR k = 1 TO 9

IF A(k) >= 9 THEN

score=score+A(k)

END IF

NEXT k

PRINT score

END

var k, score: integer;

A: array[1..9] of integer;

begin

A[1]:=6; A[2]:=11;

A[3]:=7; A[4]:=12;

A[5]:=13; A[6]:=5;

A[7]:=9; A[8]:=3;

A[9]:=4;

score:= 0;

for k:=1 to 9 do

begin

if A[k] >= 9 then

score:= score+A[k];

end;

write(score);

end.

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 30.01.15 ва­ри­ант ИН90201.

50
Задание 10 № 1081

В таб­ли­це Dat хра­нят­ся дан­ные о ко­ли­че­стве сде­лан­ных уче­ни­ка­ми за­да­ний (Dat[1] за­да­ний сде­лал пер­вый ученик, Dat[2] — вто­рой и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел­таб Dat[1:10]

цел k, m, n

Dat[1] := 7; Dat[2] := 9

Dat[3] := 10; Dat[4] := 5

Dat[5] := 6; Dat[6] := 7

Dat[7] := 9; Dat[8] := 10

Dat[9] := 6; Dat[10] := 9

m := 0 ; n := 0

нц для k от 1 до 10

если Dat[k] >= m то

m := Dat[k]

n := k

все

кц

вывод n

кон

DIM Dat(10) AS INTEGER

DIM k, m, n AS INTEGER

Dat(1) = 7: Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6: Dat(6) = 7

Dat(7) = 9: Dat(8) = 10

Dat(9) = 6: Dat(10) = 9

m = 0 : n =0

FOR k = 1 TO 10

IF Dat(k) >= m THEN

m = Dat(k)

n = k

END IF

NEXT k

PRINT n

Var k, m, n: integer;

Dat: array[1..10] of integer;

Begin

Dat[1] := 7; Dat[2] := 9;

Dat[3] := 10; Dat[4] := 5;

Dat[5] := 6; Dat[6] := 7;

Dat[7] := 9; Dat[8] := 10;

Dat[9] := 6; Dat[10] := 9;

m := 0; n := 0;

for k := 1 to 10 do

if Dat[k] >= m then

begin

m := Dat[k]; n := k

end;

writeln(n)

End.

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 30.01.15 ва­ри­ант ИН90202.

51
Задание 10 № 1104

Школьница де­ла­ла ла­бо­ра­тор­ную ра­бо­ту по физике, в ходе ко­то­рой из­ме­ри­ла 10 раз силу тока и за­пи­са­ла по­ка­за­ния ам­пер­мет­ра в таб­ли­цу Tok (Tok[1] — ре­зуль­тат пер­во­го измерения, Tok[2] — вто­ро­го и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел­таб Tok[1:10]

цел k, m

Tok[1] := 10; Tok[2] := 14

Tok[3] := 15; Tok[4] := 4

Tok[5] := 12; Tok[6] := 6

Tok[7] := 3; Tok[8] := 5

Tok[9] := 5; Tok[10] := 10

m := 0

нц для k от 1 до 10

если Tok[k] > 6 то

m := m + 2

все

кц

вывод m

кон

DIM Tok(10) AS INTEGER

DIM k,m AS INTEGER

Tok(1)= 10: Tok(2)= 14

Tok(3)= 15: Tok(4) = 4

Tok(5)= 12: Tok(6)= 6

Tok(7)= 3: Tok(8)= 5

Tok(9)= 5: Tok(10)= 10

m = 0

FOR k = 1 TO 10

IF Tok(k) > 6 THEN

m = m + 2

END IF

NEXT k

PRINT m

Var k, m: integer;

Tok: array[1..10] of integer;

Begin

Tok[1] := 10; Tok[2] := 14;

Tok[3] := 15; Tok[4] := 4;

Tok[5] := 12; Tok[6] := 6;

Tok[7] := 3; Tok[8] := 5;

Tok[9] := 5; Tok[10] := 10;

m := 0;

For k := 1 to 10 Do

If Tok[k] > 6 Then

Begin

m := m + 2;

End;

Writeln(m);

End.

Источник: СтатГрад: Тренировочная работа по ин­фор­ма­ти­ке 23.03.15 ва­ри­ант ИН90601.

52
Задание 10 № 1124

В таб­ли­це Dat хра­нят­ся дан­ные о ко­ли­че­стве сде­лан­ных уче­ни­ка­ми за­да­ний (Dat[1] за­да­ний сде­лал пер­вый ученик, Dat[2] — вто­рой и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел­таб Dat[1:10]

цел k, m

Dat[1] := 7; Dat[2] := 9

Dat[3] := 10; Dat[4] := 5

Dat[5] := 6; Dat[6] := 7

Dat[7] := 9; Dat[8] := 8

Dat[9] := 6; Dat[10] := 7

m := 0

нц для k от 1 до 10

если Dat[k] < 8 то

m := m + 1

все

кц

вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 7: Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6: Dat(6) = 7

Dat(7) = 9: Dat(8) = 8

Dat(9) = 6: Dat(10) = 7

m = 0

FOR k = 1 TO 10

IF Dat(k) < 8 THEN

m = m + 1

END IF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

Dat[1] := 7; Dat[2] := 9;

Dat[3] := 10; Dat[4] := 5;

Dat[5] := 6; Dat[6] := 7;

Dat[7] := 9; Dat[8] := 8;

Dat[9] := 6; Dat[10] := 7;

m := 0;

for k := 1 to 10 do

if Dat[k] < 8 then

begin

m := m + 1

end;

writeln(m)

End.

Источник: СтатГрад: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 23.03.15 ва­ри­ант ИН90602.

53
Задание 10 № 1144

В таб­ли­це Dat хра­нят­ся дан­ные еже­днев­ных из­ме­ре­ний ко­ли­че­ства осад­ков за не­де­лю в мил­ли­мет­рах (Dat[1] – дан­ные за понедельник, Dat[2] – за втор­ник и т.д.). Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го алгоритма, за­пи­сан­но­го на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел­таб Dat[1:7]

цел k, day

Dat[1] := 14; Dat[2] := 10

Dat[3] := 0; Dat[4] := 15

Dat[5] := 0; Dat[6] := 15

Dat[7] := 10

day := 0;

нц для k от 1 до 7

если Dat[k] = 0 то

day := k

все

кц

вывод day

кон

DIM Dat(7) AS INTEGER

Dat(1) = 14: Dat(2) = 10

Dat(3) = 0: Dat(4) = 15

Dat(5) = 0: Dat(6) = 15

Dat(7) = 10

day = 0

FOR k = 1 TO 7

IF Dat(k) = 0 THEN

day=k

ENDIF

NEXT k

PRINT day

END

var k, day: integer;

Dat: array[1..7] of integer;

begin

Dat[1] := 14; Dat[2] := 10;

Dat[3] := 0; Dat[4] := 15;

Dat[5] := 0; Dat[6] := 15;

Dat[7] := 10;

day := 0;

for k := 1 to 7 do

if Dat[k] = 0 then

day := k;

write(day);

end.

Источник: СтатГрад: Репетиционная работа по ин­фор­ма­ти­ке 24.02.15 ва­ри­ант ИН90501.

54
Задание 10 № 1164

В таб­ли­це Dat хра­нят­ся дан­ные из­ме­ре­ний сред­не­су­точ­ной тем­пе­ра­ту­ры за 10 дней в гра­ду­сах (Dat[1] — дан­ные за пер­вый день, Dat[2] — за вто­рой и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

целтаб Dat[1:10]

цел k, m

Dat[1] := 12

Dat[2] := 15

Dat[3] := 17

Dat[4] := 15

Dat[5] := 14

Dat[6] := 12

Dat[7] := 10

Dat[8] := 13

Dat[9] := 14

Dat[10] := 15

m := 20

нц для k от 1 до 10

если Dat[k] < m то

m := Dat[k]

все

кц

вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 12: Dat(2) = 15

Dat(3) = 17: Dat(4) = 15

Dat(5) = 14: Dat(6) = 12

Dat(7) = 10: Dat(8) = 13

Dat(9) = 14:Dat(10) = 15

m = 20

FOR k = 1 TO 10

IF Dat(k) < m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

Dat[1] := 12; Dat[2] := 15;

Dat[3] := 17; Dat[4] := 15;

Dat[5] := 14; Dat[6] := 12;

Dat[7] := 10; Dat[8] := 13;

Dat[9] := 14; Dat[10] := 15;

m := 20;

for k := 1 to 10 do

if Dat[k] < m then

begin

m := Dat[k]

end;

writeln(m);

End.

Источник: СтатГрад: Ре­пе­ти­ци­он­ная работа по ин­фор­ма­ти­ке 24.02.15 ва­ри­ант ИН90502.

55
Задание 10 № 1263

В таб­ли­це Dat хра­нят­ся дан­ные о ко­ли­че­стве уче­ни­ков в клас­сах (Dat[1] – ко­ли­че­ство уче­ни­ков в пер­вом классе, Dat[2] – во вто­ром и т. д.). Определите, какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

    целтаб Dat[1:11]

    цел k, m

    Dat[1] := 20; Dat[2] := 25

    Dat[3] := 19; Dat[4] := 25

    Dat[5] := 26; Dat[6] := 22

    Dat[7] := 24; Dat[8] := 28

    Dat[9] := 26; Dat[10] := 21

    Dat[11] := 27

    m := 0

    нц для k от 1 до 11

        если Dat[k] < 25 то

            m := m + 1

        все

    кц

    вывод m

кон

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20: Dat(2) = 25

Dat(3) = 19: Dat(4) = 25

Dat(5) = 26: Dat(6) = 22

Dat(7) = 24: Dat(8) = 28

Dat(9) = 26: Dat(10) = 21

Dat(11) = 27

m = 0

FOR k = 1 TO 11

IF Dat(k) < 25 THEN

m = m + 1

END IF

NEXT k

PRINT m

Var k, m: integer;

    Dat: array[1..11] of integer;

Begin

    Dat[1] := 20; Dat[2] := 25;

    Dat[3] := 19; Dat[4] := 25;

    Dat[5] := 26; Dat[6] := 22;

    Dat[7] := 24; Dat[8] := 28;

    Dat[9] := 26; Dat[10] := 21;

    Dat[11] := 27;

    m := 0;

    for k := 1 to 11 do

        if Dat[k] < 25 then

            begin

                m := m + 1

            end;

        writeln(m)

End.

Источник: СтатГрад: Ре­пе­ти­ци­он­ная ра­бо­та по ин­фор­ма­ти­ке 28.04.15 ва­ри­ант ИН90802.

Пройти тестирование по этим заданиям



     О проекте · Редакция

© Гущин Д. Д., 2011—2017


СПб ГУТ! С! Ф! У!