информатика
сайты - меню - вход - новости




Каталог заданий
Назад в каталог
Вернуться к списку прототипов этой категории
Версия для печати и копирования в MS Word
1
Задание 0 № 6373

В таблице Dat хранятся данные ежедневных измерений количества осадков за неделю в миллиметрах (Dat[1] − данные за понедельник, Dat[2] − за вторник и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

 

Алгоритмический язык

алг

нач

целтаб Dat[1:7]

цел  k, m, day

Dat[1] := 14;

Dat[2] := 10

Dat[3] := 0; Dat[4] := 15

Dat[5] := 0;  Dat[6] := 15

Dat[7] := 10

day := 1; m := Dat[1]

нц для k от 2 до 7

если Dat[k] > m то

m := Dat[k]

day := k

все

кц

вывод day

кон

Бейсик

Паскаль

DIM Dat(7) AS INTEGER

Dat(1) = 14:  Dat(2) = 10

Dat(3) = 0: Dat(4) = 15

Dat(5) = 0:  Dat(6) = 15

Dat(7) = 10

day = 1: m = Dat(1)

FOR k = 2 TO 7

IF Dat(k) > m THEN

m = Dat(k)

day = k

END IF

NEXT k

PRINT day

END

var k, m, day: integer;

Dat: array[1..7] of integer;

begin

Dat[1] := 14;  Dat[2] := 10;

Dat[3] := 0; Dat[4] := 15;

Dat[5] := 0;  Dat[6] := 15;

Dat[7] := 10; 

day := 1; m := Dat[1];

for k := 2 to 7 do

if  Dat[k] > m then

 begin

m := Dat[k];

day := k

 end;

write(day);

end.


 

 


Аналоги к заданию № 4949: 5785 6373 Все

Прототип задания ·