информатика
сайты - меню - вход - новости




Каталог заданий
Назад в каталог
Вернуться к списку прототипов этой категории
Версия для печати и копирования в MS Word
1
Задание 0 № 6184

В таблице Dat хранятся данные ежедневных измерений количества осадков за неделю в миллиметрах (Dat[1] − данные за понедельник, Dat[2] − за вторник и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

 

Алгоритмический язык

алг

нач

целтаб Dat[1:7]

цел  k, day

Dat[1] := 14;  Dat[2] := 10

Dat[3] := 0; Dat[4] := 15

Dat[5] := 0;  Dat[6] := 15

Dat[7] := 10

day := 0;

нц для k от 1 до 7

если Dat[k] = 0 то

day := k

все

кц

вывод day

кон

Бейсик

Паскаль

DIM Dat(7) AS INTEGER

Dat(1) = 14:  Dat(2) = 10

Dat(3) = 0: Dat(4) = 15

Dat(5) = 0:  Dat(6) = 15

Dat(7) = 10

day = 0

FOR k = 1 TO 7

IF Dat(k) = 0 THEN

day = k

END IF

NEXT k

PRINT day

END

var k, day: integer;

Dat: array[1..7] of integer;

begin

Dat[1] := 14;  Dat[2] := 10;

Dat[3] := 0; Dat[4] := 15;

Dat[5] := 0;  Dat[6] := 15;

Dat[7] := 10; 

day := 0;

for k := 1 to 7 do

if  Dat[k] = 0 then

day := k;

write(day);

end.


 

 


Аналоги к заданию № 5964: 6115 6184 Все

Прототип задания ·