информатика
сайты - меню - вход - новости




Каталог заданий
Назад в каталог
Вернуться к списку прототипов этой категории
Версия для печати и копирования в MS Word
1
Задание 0 № 6126

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

 

Алгоритмический язык

алг

нач

  цел k,i

  k := 4

  нц для i от 1 до 3

        k := 2 * k + i

  кц

  вывод k

кон

Бейсик

DIM i,k AS INTEGER

k = 4

FOR i = 1 TO 3

  k = 2 * k + i

NEXT i

PRINT k

END

Паскаль

var k,i: integer;

begin

  k := 4;

  For i := 1 to 3 do

     k := 2 * k + i;

  Writeln(k);

end.


 

Прототип задания ·