информатика
сайты - меню - вход - новости




Каталог заданий
Назад в каталог
Вернуться к списку прототипов этой категории
Версия для печати и копирования в MS Word
1
Задание 0 № 6115

 

В таблице Dat хранятся данные ежедневных измерений температуры морской воды (Dat[1] − температура в понедельник, Dat[2] − во вторник и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

 

Алгоритмический язык

алг

нач

целтаб Dat[1:7]

цел  k, day

Dat[1] := 19;  Dat[2] := 21

Dat[3] := 20;  Dat[4] := 23

Dat[5] := 24;  Dat[6] := 25

Dat[7] := 23

day := Dat[1]

нц для k от 1 до 7

если Dat[k] > day то

day := Dat[k]

все

кц

вывод day

кон

Бейсик

Паскаль

DIM Dat(7) AS INTEGER

DIM k, day AS INTEGER

Dat(1) = 19:  Dat(2) = 21

Dat(3) = 20: Dat(4) = 23

Dat(5) = 24:  Dat(6) = 25

Dat(7) = 23

day = Dat(1)

FOR k = 1 TO 7

IF Dat(k) > day THEN

day = Dat(k)

END IF

NEXT k

PRINT day

END

var

Dat: array[1..7] of integer;

k, day: integer;

begin

Dat[1] := 19;  Dat[2] := 21;

Dat[3] := 20; Dat[4] := 23;

Dat[5] := 24;  Dat[6] := 25;

Dat[7] := 23; 

day := Dat[1];

for k := 1 to 7 do

if  Dat[k] > day then

day := Dat[k];

writeln(day);

end.


 

 


Аналоги к заданию № 5964: 6184 Все

Прототип задания ·