информатика
сайты - меню - вход - новости




Каталог заданий
Назад в каталог
Вернуться к списку прототипов этой категории
Версия для печати и копирования в MS Word
1
Задание 0 № 5933

В таблице A хранятся данные о количестве учеников опоздавших на занятия  за неделю (A[1] − данные за понедельник, A[2] − за вторник и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

 

Алгоритмический язык

алг

нач

  целтаб A[1:6]

  цел k, m, day

  A[1] := 5; A[2] := 4

  A[3] := 2; A[4] := 2

  A[5] := 4; A[6] := 3

  day := 1; m := A[1]

  нц для k от 2 до 6

    если A[k] <= m то

     m := A[k]

     day := k

    все

  кц

  вывод day

кон

Бейсик

Паскаль

DIM A(6) AS INTEGER

A(1) = 5: A(2) = 4

A(3) = 2: A(4) = 2

A(5) = 4: A(6) = 3

day = 1: m = A(1)

FOR k = 2 TO 6

 IF A(k) <= m THEN

  m = A(k)

  day = k

 END IF

NEXT k

PRINT day

END

var k, m, day: integer;

A: array[1..6] of integer;

begin

  A[1] := 5; A[2] := 4;

  A[3] := 2; A[4] := 2;

  A[5] := 4; A[6] := 3;

  day := 1; m := A[1];

  for k := 2 to 6 do

    begin

      if A[k] <= m then

        begin

          m := A[k];

          day := k

        end;

  write(day);

end.


 

 

Прототип задания ·