информатика
сайты - меню - вход - новости




Каталог заданий
Назад в каталог
Вернуться к списку прототипов этой категории
Версия для печати и копирования в MS Word
1
Задание 0 № 5438

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

 

Алгоритмический язык

алг

нач

   цел k,i

   k := 2

   нц для i от 0 до 2

         k := 3 * k + i

   кц

   вывод k

кон

Бейсик

DIM i,k AS INTEGER

k = 2

FOR i = 0 TO 2

  k = 3 * k + i

NEXT i

PRINT k

END

Паскаль

var k,i: integer;

begin

  k := 2;

  for i := 0 to 2 do

     k := 3 * k + i;

  writeln(k);

end.


 

 

Прототип задания ·