информатика
сайты - меню - вход - новости




Каталог заданий
Назад в каталог
Вернуться к списку прототипов этой категории
Версия для печати и копирования в MS Word
1
Задание 0 № 5136

В таблице Dat хранятся данные измерений среднесуточной температуры за неделю в градусах (Dat[1] − данные за понедельник, Dat[2] − за вторник и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:7]

  цел k, m

  Dat[1] := 15; Dat[2] := 18

  Dat[3] := 22; Dat[4] := 20

  Dat[5] := 23; Dat[6] := 24

  Dat[7] := 20

  m:= 0

  нц для k от 1 до 7

    если Dat[k] > 20 то

      m := m + 1

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(7) AS INTEGER

Dat(1) = 15: Dat(2) = 18

Dat(3) = 22: Dat(4) = 20

Dat(5) = 23: Dat(6) = 24

Dat(7) = 20

m = 0

FOR k = 1 TO 7

 IF Dat(k) > 20 THEN

  m = m + 1  

 END IF

NEXT k

PRINT m

END

var k, m: integer;

Dat: array[1..7] of integer;

begin

  Dat[1] := 15; Dat[2] := 18;

  Dat[3] := 22; Dat[4] := 20;

  Dat[5] := 23; Dat[6] := 24;

  Dat[7] := 20;

  m := 0;

  for k := 1 to 7 do begin

    if Dat[k] > 20 then

      m := m + 1;

  end;

  write(m);

end.


 

 


Аналоги к заданию № 4747: 5136 Все

Прототип задания ·