информатика
сайты - меню - вход - новости




Каталог заданий
Назад в каталог
Вернуться к списку прототипов этой категории
Версия для печати и копирования в MS Word
1
Задание 0 № 5044

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] − второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 9; Dat[8] := 8

  Dat[9] := 6; Dat[10] := 9

  m := 0

  нц для k от 1 до 10

    если Dat[k] > m  то

     m := Dat[k]

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 9:  Dat(8) = 8

Dat(9) = 6:  Dat(10) = 9

m = 0 

FOR k = 1 TO 10

 IF Dat(k) > m THEN

  m = Dat(k)

 END IF

NEXT k

PRINT m

END

var k, m: integer;

 Dat: array[1..10] of integer;

begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 8;

  Dat[9] := 6;  Dat[10] := 9;

  m := 0;

  for k := 1  to 10 do

    if  Dat[k] > m then

      m := Dat[k];

  writeln(m)

end.


 

Прототип задания ·