информатика
сайты - меню - вход - новости




Варианты заданий
Версия для печати и копирования в MS Word
1
Задание 0 № 4759

В таблице Dat хранятся данные о количестве сделанных заданий учениками (Dat[1] заданий сделал первый ученик, Dat[2] − второй и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

 

Алгоритмический язык

Бейсик

алг

нач

  целтаб Dat[1:10]

  цел  k, m, n

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 9; Dat[8] := 8

  Dat[9] := 9; Dat[10] := 9

  m := 1;n := 0

  нц для k от 1 до 10

    если Dat[k] > m  то

      m := Dat[k]

      n := k

    все

  кц

  вывод n

кон

DIM Dat(10) AS INTEGER

DIM k, m, n AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 9:  Dat(8) = 8

Dat(9) = 9:  Dat(10) = 9

m = 1: n = 0

FOR k = 1 TO 10

 IF Dat(k) > m THEN

  m = Dat(k)

  n = k

 END IF

NEXT k

PRINT n

END

Паскаль

var k, m, n: integer;

Dat: array[1..10] of integer;

begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 8;

  Dat[9] := 9;  Dat[10] := 9;

  m := 1; n := 0;

  for k := 1 to 10 do

    if  Dat[k] > m then

      begin

        m := Dat[k];

        n := k

      end;

  writeln(n)

end.


 


2
Задание 0 № 4788

В таблице Dat хранятся данные о количестве сделанных заданий учениками (Dat[1] заданий сделал первый ученик, Dat[2] − второй и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

 

Алгоритмический язык

Бейсик

алг

нач

  целтаб Dat[1:10]

  цел  k, n

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 9; Dat[8] := 8

  Dat[9] := 9; Dat[10] := 9

  n := 0

  нц для k от 1 до 10

    если Dat[k] < 8  то

       n := n + 1

    все

  кц

  вывод n

кон

DIM Dat(10) AS INTEGER

DIM k, n AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 9:  Dat(8) = 8

Dat(9) = 9:  Dat(10) = 9

n = 0

FOR k = 1 TO 10

 IF Dat(k) < 8 THEN

  n = n+1

 END IF

NEXT k

PRINT n

END

 

Паскаль

var k, n: integer;

Dat: array[1..10] of integer;

begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 8;

  Dat[9] := 9;  Dat[10] := 9;

  n := 0;

  for k := 1 to 10 do

    if  Dat[k] < 8 then

      n := n + 1;

  writeln(n)

end.


 


3
Задание 0 № 4888

В таблице Dat хранятся данные о количестве сделанных заданий учениками (Dat[1] заданий сделал первый ученик, Dat[2] − второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m, n

  Dat[1] := 7

  Dat[2] := 9

  Dat[3] := 10

  Dat[4] := 5

  Dat[5] := 6

  Dat[6] := 7

  Dat[7] := 9

  Dat[8] := 8

  Dat[9] := 6

  Dat[10] := 9

  m := 10; n := 0

  нц для k от 1 до 10

    если Dat[k] < m то

      m := Dat[k]

      n := k

    все

  кц

  вывод n

кон

DIM Dat(10) AS INTEGER

DIM k, m, n AS INTEGER

Dat(1) = 7

Dat(2) = 9

Dat(3) = 10

Dat(4) = 5

Dat(5) = 6

Dat(6) = 7

Dat(7) = 9

Dat(8) = 8

Dat(9) = 6

Dat(10) = 9

m = 10: n = 0

FOR k = 1 TO 10

 IF Dat(k) < m THEN

  m = Dat(k)

  n = k

 END IF

NEXT k

PRINT n

END

var k, m, n: integer;

Dat: array[1..10] of integer;

begin

  Dat[1] := 7;

  Dat[2] := 9;

  Dat[3] := 10;

  Dat[4] := 5;

  Dat[5] := 6;

  Dat[6] := 7;

  Dat[7] := 9;

  Dat[8] := 8;

  Dat[9] := 6;

  Dat[10] := 9;

  m := 10; n := 0;

  for k := 1 to 10 do

    if  Dat[k] < m then

      begin

        m := Dat[k];

        n := k

      end;

  writeln(n)

end.


 


4
Задание 0 № 4948

В таблице Dat хранятся данные о количестве учеников в классах (Dat[1] − количество учеников в первом классе, Dat[2] − во втором и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

 

Алгоритмический язык

Бейсик

алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1] := 20; Dat[2] := 25

  Dat[3] := 19; Dat[4] := 25

  Dat[5] := 26; Dat[6] := 22

  Dat[7] := 24; Dat[8] := 28

  Dat[9] := 26; Dat[10] := 21

  Dat[11] := 27

  m := 0

  нц для k от 1 до 11

    если Dat[k] > m  то

       m := Dat[k]

    все

  кц

  вывод m

кон

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20: Dat(2) = 25

Dat(3) = 19: Dat(4) = 25

Dat(5) = 26: Dat(6) = 22

Dat(7) = 24: Dat(8) = 28

Dat(9) = 26: Dat(10) = 21

Dat(11) = 27

m = 0 

FOR k = 1 TO 11

 IF Dat(k) > m THEN

  m = Dat(k)

 END IF

NEXT k

PRINT m

END

Паскаль

var k, m: integer;

Dat: array[1..11] of integer;

begin

  Dat[1] := 20;  Dat[2] := 25;

  Dat[3] := 19;  Dat[4] := 25;

  Dat[5] := 26;  Dat[6] := 22;

  Dat[7] := 24;  Dat[8] := 28;

  Dat[9] := 26;  Dat[10] := 21;

  Dat[11] := 27;

  m := 0;

  for k := 1 to 11 do

    if  Dat[k] > m then

       m := Dat[k];

  writeln(m)

end.


 


5
Задание 0 № 5245

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] − второй и т.д.). Определите число, которое будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

алг

нач

  целтаб Dat[1:10]

  цел  k, m, n

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 9; Dat[8] := 10

  Dat[9] := 6; Dat[10] := 9

  m := 0; n := 0

  нц для k от 1 до 10

    если Dat[k] >= m  то

      m := Dat[k]

      n := k

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(10) AS INTEGER

DIM k, m, n AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 9:  Dat(8) = 10

Dat(9) = 6:  Dat(10) = 9

m = 0: n = 0

FOR k = 1 TO 10

 IF Dat(k) >= m THEN

  m = Dat(k)

  n = k

 END IF

NEXT k

PRINT m

END

var k, m, n: integer;

Dat: array[1..10] of integer;

begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 10;

  Dat[9] := 6;  Dat[10] := 9;

  m := 0; n := 0;

  for k := 1 to 10 do

    if  Dat[k] >= m then

      begin

        m := Dat[k];

        n := k

      end;

  writeln(m);

end.


 


6
Задание 0 № 5290

В таблице Dat хранятся данные о количестве учеников в классах (Dat[1] − количество учеников в первом классе, Dat[2] − во втором и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

 

 

Алгоритмический язык

Бейсик

алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1] := 20; Dat[2] := 25

  Dat[3] := 19; Dat[4] := 25

  Dat[5] := 26; Dat[6] := 22

  Dat[7] := 24; Dat[8] := 28

  Dat[9] := 26; Dat[10] := 21

  Dat[11] := 27

  m := 30

  нц для k от 1 до 11

    если Dat[k] < m  то

       m: = Dat[k]

    все

  кц

  вывод m

кон

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20: Dat(2) = 25

Dat(3) = 19: Dat(4) = 25

Dat(5) = 26: Dat(6) = 22

Dat(7) = 24: Dat(8) = 28

Dat(9) = 26: Dat(10) = 21

Dat(11) = 27

m = 30 

FOR k = 1 TO 11

 IF Dat(k) < m THEN

  m = Dat(k)

 END IF

NEXT k

PRINT m

END

Паскаль

var k, m: integer;

Dat: array[1..11] of integer;

begin

  Dat[1] := 20;  Dat[2] := 25;

  Dat[3] := 19;  Dat[4] := 25;

  Dat[5] := 26;  Dat[6] := 22;

  Dat[7] := 24;  Dat[8] := 28;

  Dat[9] := 26;  Dat[10] := 21;

  Dat[11] := 27;

  m := 30;

  for k := 1 to 11 do

    if  Dat[k] < m then

       m := Dat[k];

  writeln(m)

end.


 


7
Задание 0 № 5342

В таблице Dat хранятся данные о количестве учеников в классах (Dat[1] − количество учеников в первом классе, Dat[2] − во втором и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

 

Алгоритмический язык

Бейсик

алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1] := 20; Dat[2] := 25

  Dat[3] := 19; Dat[4] := 25

  Dat[5] := 26; Dat[6] := 22

  Dat[7] := 24; Dat[8] := 28

  Dat[9] := 26; Dat[10] := 21

  Dat[11] := 27

  m := 0

  нц для k от 1 до 11

    если Dat[k] > 24  то

      m := m + 1

    все

  кц

  вывод m

кон

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20: Dat(2) = 25

Dat(3) = 19: Dat(4) = 25

Dat(5) = 26: Dat(6) = 22

Dat(7) = 24: Dat(8) = 28

Dat(9) = 26: Dat(10) = 21

Dat(11) = 27

m = 0 

FOR k = 1 TO 11

 IF Dat(k) > 24 THEN

  m = m + 1

 END IF

NEXT k

PRINT m

END

Паскаль

var k, m: integer;

Dat: array[1..11] of integer;

begin

  Dat[1] := 20;  Dat[2] := 25;

  Dat[3] := 19;  Dat[4] := 25;

  Dat[5] := 26;  Dat[6] := 22;

  Dat[7] := 24;  Dat[8] := 28;

  Dat[9] := 26;  Dat[10] := 21;

  Dat[11] := 27;

  m := 0;

  for k := 1 to 11 do

    if  Dat[k] > 24 then

        m := m + 1;

  writeln(m)

end.


 


8
Задание 0 № 5861

В таблице Dat хранятся данные о количестве учеников в классах (Dat[1] − количество учеников в первом классе, Dat[2] − во втором и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1] := 20

  Dat[2] := 27

  Dat[3] := 19

  Dat[4] := 28

  Dat[5] := 26

  Dat[6] := 22

  Dat[7] := 24

  Dat[8] := 28

  Dat[9] := 26

  Dat[10] := 21

  Dat[11] := 27

  m := 0

  нц для k от 1 до 11

    если Dat[k] < 25 то

     m := m + 1

    все

  кц

  вывод m

кон

 

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20

Dat(2) = 27

Dat(3) = 19

Dat(4) = 28

Dat(5) = 26

Dat(6) = 22

Dat(7) = 24

Dat(8) = 28

Dat(9) = 26

Dat(10) = 21

Dat(11) = 27

m = 0 

FOR k = 1 TO 11

 IF Dat(k) < 25 THEN

  m = m + 1

 END IF

NEXT k

PRINT m

END

 

var k, m: integer;

 Dat: array[1..11] of integer;

begin

  Dat[1] := 20;

  Dat[2] := 27;

  Dat[3] := 19;

  Dat[4] := 28;

  Dat[5] := 26;

  Dat[6] := 22;

  Dat[7] := 24;

  Dat[8] := 28;

  Dat[9] := 26;

  Dat[10] := 21;

  Dat[11] := 27;

  m := 0;

  for k := 1 to 11 do

    if  Dat[k] < 25 then

      m := m + 1;

  writeln(m)

end.


 


9
Задание 0 № 6030

В таблице Dat хранятся данные о количестве учеников в классах (Dat[1] − количество учеников в первом классе, Dat[2] − во втором и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

 

Алгоритмический язык

Бейсик

алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1] := 20; Dat[2] := 25

  Dat[3] := 19; Dat[4] := 25

  Dat[5] := 26; Dat[6] := 23

  Dat[7] := 24; Dat[8] := 28

  Dat[9] := 26;Dat[10] := 21

  Dat[11] := 27

  m := 0

  нц для k от 1 до 11

    если Dat[k] < 23  то

      m:=m + Dat[k]

    все

  кц

  вывод m

кон

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20: Dat(2) = 25

Dat(3) = 19: Dat(4) = 25

Dat(5) = 26: Dat(6) = 23

Dat(7) = 24: Dat(8) = 28

Dat(9) = 26: Dat(10) = 21

Dat(11) = 27

m = 0 

FOR k = 1 TO 11

 IF Dat(k) < 23 THEN

  m = m + Dat(k)

 END IF

NEXT k

PRINT m

END

Паскаль

var k, m: integer;

Dat: array[1..11] of integer;

begin

  Dat[1] := 20;  Dat[2] := 25;

  Dat[3] := 19;  Dat[4] := 25;

  Dat[5] := 26;  Dat[6] := 23;

  Dat[7] := 24;  Dat[8] := 28;

  Dat[9] := 26;  Dat[10] := 21;

  Dat[11] := 27;

  m := 0;

  for k := 1 to 11 do

    if  Dat[k] < 23 then

        m := m + Dat[k];

  writeln(m)

end.


 


10
Задание 0 № 6489

В таблице Dat хранятся данные о количестве сделанных заданий учениками (Dat[1] заданий сделал первый ученик, Dat[2] − второй и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

 

Алгоритмический язык

Бейсик

алг

нач

  целтаб Dat[1:10]

  цел  k, n

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 9; Dat[8] := 8

  Dat[9] := 9; Dat[10] := 9

  n := 0

  нц для k от 1 до 10

    если Dat[k] > 7  то

      n := n + 1

    все

  кц

  вывод n

кон

DIM Dat(10) AS INTEGER

DIM k, n AS INTEGER

Dat(1) = 7: Dat(2) = 9

Dat(3) = 10:Dat(4) = 5

Dat(5) = 6: Dat(6) = 7

Dat(7) = 9: Dat(8) = 8

Dat(9) = 9: Dat(10) = 9

n = 0

FOR k = 1 TO 10

 IF Dat(k) > 7 THEN

  n = n + 1

 END IF

NEXT k

PRINT n

END

Паскаль

var k, n: integer;

Dat: array[1..10] of integer;

begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 8;

  Dat[9] := 9;  Dat[10] := 9;

  n := 0;

  for k := 1 to 10 do

    if  Dat[k] > 7 then

      n := n + 1;

  writeln(n)

end.