СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Каталог заданий
Задания Д9. Простейший циклический алгоритм, записанный на алгоритмическом языке

Пройти тестирование по 10 заданиям
Пройти тестирование по всем заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задания Д9 № 9

За­пи­ши­те зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей про­грам­мы. Текст про­грам­мы при­ведён на пяти язы­ках про­грам­ми­ро­ва­ния.

 

Бей­сикPython

DIM k, s AS INTEGER

s = 0

FOR k = 3 TO 7

s = s + 6

NEXT k

PRINT s

s = 0

for k in range(3,8):

    s = s + 6

print (s)

Пас­кальАл­го­рит­ми­че­ский язык

var s,k: integer;

begin

   s := 0;

   for k := 3 to 7 do

      s := s + 6;

   writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 3 до 7

      s := s + 6

   кц

вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 3; k <= 7; k++)

          s += 6;

     cout << s;

     return 0;

}

 

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1301.

2
Задания Д9 № 29

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 0

FOR k = 4 TO 8

    s = s + 7

NEXT k

PRINT s

s = 0

for k in range(4,9):

    s = s + 7

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 0;

    for k := 4 to 8 do

        s := s + 7;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 4 до 8

      s := s + 7

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 4; k <= 8; k++)

          s += 7;

     cout << s;

     return 0;

}

 

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1302.

3
Задания Д9 № 49

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 0

FOR k = 4 TO 7

    s = s + 8

NEXT k

PRINT s

s = 0

for k in range(4,8):

    s = s + 8

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 0;

    for k := 4 to 7 do

        s := s + 8;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 4 до 7

      s := s + 8

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 4; k <= 7; k++)

          s += 8;

     cout << s;

     return 0;

}

 

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1303.

4
Задания Д9 № 69

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 0

FOR k = 3 TO 8

    s = s + 9

NEXT k

PRINT s

s = 0

for k in range(3,9):

    s = s + 9

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 0;

    for k := 3 to 8 do

        s := s + 9;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 3 до 8

      s := s + 9

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 3; k <= 8; k++)

          s += 9;

     cout << s;

     return 0;

}

 

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1304.

5
Задания Д9 № 89

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 0

FOR k = 3 TO 8

    s = s + 7

NEXT k

PRINT s

s = 0

for k in range(3,9):

    s = s + 7

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 0;

    for k := 3 to 8 do

        s := s + 7;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 3 до 8

      s := s + 7

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 3; k <= 8; k++)

          s += 7;

     cout << s;

     return 0;

}

 

Источник: ГИА по информатике 31.05.2013. Основная волна. Сибирь, Даль­ний Восток. Вариант 1305.

Пройти тестирование по этим заданиям