№№ заданий Пояснения Ответы Ключ Добавить инструкцию Критерии
Источник Раздел кодификатора ФИ­ПИ
PDF-версия PDF-версия (вертикальная) PDF-версия (крупный шрифт) PDF-версия (с большим полем) Версия для копирования в MS Word
Задания
Задания Д17 C1 № 898

В издательстве детских книг данные об изданных книгах хранятся в электронной таблице. Ниже приведены первые пять строк таблицы.

 

ABCD
1АвторНазвание книгиГод создания произведенияРейтинг книги
2Агния БартоСтихи для детей1925316
3Алан Александр МилнВинни-Пух1928254
4Александр ВолковВолшебник Изумрудного города19391235
5Александр ПушкинРуслан и Людмила18201472
6Александр ПушкинСказка о царе Салтане1831900

 

Каждая строка таблицы содержит запись об одной книге. В столбце A записан автор книги; в столбце B — название книги; в столбце C — год создания произведения; в столбце D — рейтинг книги. Всего в электронную таблицу были занесены данные по 134 книгам в произвольном порядке.

 

 

task19.xls

 

Выполните задание.

Откройте файл с данной электронной таблицей. На основании данных, содержащихся в этой таблице, ответьте на два вопроса.

 

1. Какое количество произведений написано позже 1930 года? Ответ на этот вопрос запишите в ячейку E2 таблицы.

2. Какой процент книг, написанных ранее 1900 года, имеет рейтинг больше 1000? Ответ на этот вопрос с точностью не менее двух знаков после запятой запишите в ячейку E3 таблицы.

Решение.

Решение для OpenOffice.org Calc и для Microsoft Excel

 

Первая формула используется для русскоязычной записи функций, вторая — для англоязычной.

 

Для ответа на первый вопрос в ячейку E2 запишем формулу

=СЧЁТЕСЛИ(C2:C135;">1930")

=COUNTIF(C2:C135;" >1930")

 

Для ответа на второй вопрос в столбце F для каждой книги запишем её рейтинг, если её издали ранее 1900 года, и 0 в обратном случае. В ячейку F2 запишем формулу

 

=ЕСЛИ(C2<1900;D2;0)

=IF(C2<1900;D2;0)

 

Скопируем формулу во все ячейки диапазона F2:F135. Далее, чтобы определить книги, рейтинг которых больше 1000, запишем в ячейку G2 формулу

 

=СЧЁТЕСЛИ(F2:F135;">1000")

=COUNTIF(F2:F135;">1000")

 

Сосчитаем количество книг, изданных ранее 1900 года. В ячейку G3 запишем формулу:

 

=СЧЁТЕСЛИ(C2:C135;"<1900")

=COUNTIF(C2:C135;"<1900")

 

Для получения окончательного ответа запишем в ячейку E3 формулу

 

=G2*100/G3

 

Возможны и другие способы решения задачи.

 

Если задание выполнено правильно и использовались файлы, специально подготовленные для проверки выполнения данного задания, то должны получиться следующие ответы:

на первый вопрос — 89;

на второй вопрос — 42,31.