№№ заданий Пояснения Ответы Ключ Добавить инструкцию Критерии
Источник Раздел кодификатора ФИ­ПИ
PDF-версия PDF-версия (вертикальная) PDF-версия (крупный шрифт) PDF-версия (с большим полем) Версия для копирования в MS Word
Задания
Задания Д6 № 1017

Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n — целое число), вызывающая передвижение Черепашки на n шагов в направлении движения; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке. Запись Повтори k [Команда1 Команда2 КомандаЗ] означает, что последовательность команд в скобках повторится k раз.

При выполнении какого из перечисленных ниже алгоритмов на экране появился правильный треугольник?

 

1) Повтори 3 [Вперёд 50 Направо 20 Направо 25]

2) Повтори 3 [Вперёд 50 Направо 100 Направо 20]

3) Повтори 6 [Вперёд 50 Направо 10 Направо 20]

4) Повтори 6 [Вперёд 50 Направо 20 Направо 40]

Решение.

Углы правильного треугольника равны 60°. Следовательно, после движения вперёд, Черепашка должна изменять направление движения на 180 — 60 = 120°. Это условие выполняется для алгоритма под номером 2, поскольку 100 + 20 = 120°.

 

Правильный ответ указан под номером 2.